;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2014 Sree Harsha Totakura ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages dc) #:use-module (gnu packages) #:use-module (gnu packages compression) #:use-module (gnu packages glib) #:use-module (gnu packages ncurses) #:use-module (gnu packages pkg-config) #:use-module (gnu packages sqlite) #:use-module (gnu packages tls) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module ((guix licenses) #:prefix license:)) (define-public ncdc (package (name "ncdc") (version "1.22.1") (source (origin (method url-fetch) (uri (string-append "http://dev.yorhel.nl/download/ncdc-" version ".tar.gz")) (sha256 (base32 "1bdgqd07f026qk6vpbxqsin536znd33931m3b4z44prlm9wd6pyi")))) (build-system gnu-build-system) (inputs (list bzip2 glib gnutls ncurses sqlite zlib)) (native-inputs (list pkg-config)) (home-page "https://dev.yorhel.nl/ncdc") (synopsis "Lightweight direct connect client with a friendly ncurses interface") (description "Ncdc is a client for the Direct Connect peer-to-peer protocol implemented using ncurses. It is known for its smaller footprint and ease of use.") (license license:x11))) i.scm?id=13fd321a4968b537d56c053a14d6953f2677227b'>ci.scm
AgeCommit message (Expand)Author
2024-07-10gnu: ci: Cross-build for fewer platforms....Efraim Flashner
2024-06-13ci: Add cross-compilation jobs for x86_64-linux-gnux32....Ludovic Courtès
2024-05-31ci: Build visionfive2-barebones-raw-image....Zheng Junjie
2024-04-17ci: Don’t cross-compile to xtensa-ath9k-elf....Ludovic Courtès
2024-01-23ci: Don't cross compile to or1k-elf....Mathieu Othacehe
2023-12-18gnu: ci: Build tuned packages for common baselines....Efraim Flashner
2023-12-12ci: Don't cross compile to avr....Efraim Flashner
2023-09-20image: Introduce the mbr-hybrid-raw image type....Mathieu Othacehe
2023-08-21ci: Really honor system type for manifests....Ludovic Courtès
2023-08-21ci: Honor user-specific systems for manifests....Ludovic Courtès
2023-08-18gnu: commencement: Use system in %final-inputs....Christopher Baines
2023-04-18ci: Add 'gdb-minimal' to the "core" package set....Ludovic Courtès
2023-03-09ci: Update the list of GCC versions for the 'core' subset....Ludovic Courtès