;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2014 Sree Harsha Totakura ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages dc) #:use-module (gnu packages) #:use-module (gnu packages compression) #:use-module (gnu packages glib) #:use-module (gnu packages ncurses) #:use-module (gnu packages pkg-config) #:use-module (gnu packages sqlite) #:use-module (gnu packages tls) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module ((guix licenses) #:prefix license:)) (define-public ncdc (package (name "ncdc") (version "1.22.1") (source (origin (method url-fetch) (uri (string-append "http://dev.yorhel.nl/download/ncdc-" version ".tar.gz")) (sha256 (base32 "1bdgqd07f026qk6vpbxqsin536znd33931m3b4z44prlm9wd6pyi")))) (build-system gnu-build-system) (inputs `(("bzip2" ,bzip2) ("glib" ,glib) ("gnutls" ,gnutls) ("ncurses" ,ncurses) ("sqlite" ,sqlite) ("zlib" ,zlib))) (native-inputs `(("pkg-config" ,pkg-config))) (home-page "https://dev.yorhel.nl/ncdc") (synopsis "Lightweight direct connect client with a friendly ncurses interface") (description "Ncdc is a client for the Direct Connect peer-to-peer protocol implemented using ncurses. It is known for its smaller footprint and ease of use.") (license license:x11))) /a>/packages/emacs.scm
AgeCommit message (Expand)Author
2020-12-01gnu: emacs-next-pgtk: Update to savannah feature/pgtk branch....Ryan Prior
2020-11-26gnu: Add emacs-next-pgtk....Andrew Tropin
2020-11-11gnu: emacs.scm: Remove unused module import....Marius Bakke
2020-11-03Revert "gnu: emacs: Make strip-double-wrap more robust."...Nicolas Goaziou
2020-11-03gnu: emacs: Make strip-double-wrap more robust....Morgan Smith
2020-10-01gnu: emacs-next: Fix load path and version....Morgan Smith
2020-09-02gnu: Add emacs-next....Morgan Smith
2020-08-31gnu: emacs: Strip double wrap....Leo Prikler
2020-08-29Revert "gnu: emacs: Strip double wrap."...Mathieu Othacehe
2020-08-29gnu: emacs: Strip double wrap....Leo Prikler
2020-08-28gnu: emacs: Update to 27.1....Mark H Weaver
2020-08-03gnu: emacs: Ignore empty XIM styles....Leo Prikler
2020-05-13mailmap: Update entries for Nikita....nikita
2020-05-10gnu: emacs: Remove unneeded import....Ludovic Courtès
2020-05-06Merge branch 'master' into core-updatesMarius Bakke
2020-05-05gnu: emacs-next: Upgrade to 27.0.91....Jack Hill
2020-04-30Merge branch 'master' into core-updates...Marius Bakke
2020-04-28gnu: Add emacs-wide-int....Diego Nicola Barbato