;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2014, 2018 Eric Bavier ;;; Copyright © 2016, 2017, 2018, 2019, 2020 Efraim Flashner ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages datamash) #:use-module (guix packages) #:use-module (guix licenses) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module (gnu packages) #:use-module (gnu packages perl) #:use-module (gnu packages base)) (define-public datamash (package (name "datamash") (version "1.7") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/datamash/datamash-" version ".tar.gz")) (sha256 (base32 "1cxdlhgz3wzjqlq8bgwad93fgqymk2abbldfzw1ffnhcp4mmjjjp")))) (native-inputs `(("which" ,which) ;for tests ("perl" ,perl))) ;for help2man (build-system gnu-build-system) (home-page "https://www.gnu.org/software/datamash/") (synopsis "Scriptable statistics and data calculation") (description "Perform basic numeric, textual and statistical operations on plain text files. Designed to work within standard pipelines without additional code.") (license gpl3+))) tr>
AgeCommit message (Expand)Author
2020-10-05build: Use a 'guile' executable that doesn't warn about locales....Ludovic Courtès
2020-08-29build: Remove references to the 'nix-hash' program....Ludovic Courtès
2020-08-29build: Remove check for Guile 2.2.1 bug....Ludovic Courtès
2020-08-24Use "guile-zlib" and "guile-lzlib" instead of (guix config)....Mathieu Othacehe
2020-06-16etc: Add committer script....Ricardo Wurmus
2020-05-28maint: Check whether Guile-Gcrypt is recent enough....Ludovic Courtès
2020-05-14etc: indent-code.el: Use the --quick option....Maxim Cournoyer
2020-04-23build: Don't build man pages when cross-compiling....Ludovic Courtès
2020-03-11build: Require Guile 2.2.3 or later....Ludovic Courtès
2020-01-17build: Allow builds with Guile 3.0....Ludovic Courtès
2019-11-09build: Warn about etc/indent-code.el when Emacs is absent....zimoun
2019-07-25maint: Switch to Guile-JSON 3.x....Ludovic Courtès
2019-05-06Add (guix lzlib)....Pierre Neidhardt
2019-04-17build: No longer substitute 'LIBGCRYPT'....Ludovic Courtès