;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2014, 2018 Eric Bavier ;;; Copyright © 2016, 2017, 2018, 2019, 2020 Efraim Flashner ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages datamash) #:use-module (guix packages) #:use-module (guix licenses) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module (gnu packages) #:use-module (gnu packages perl) #:use-module (gnu packages base)) (define-public datamash (package (name "datamash") (version "1.7") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/datamash/datamash-" version ".tar.gz")) (sha256 (base32 "1cxdlhgz3wzjqlq8bgwad93fgqymk2abbldfzw1ffnhcp4mmjjjp")))) (native-inputs `(("which" ,which) ;for tests ("perl" ,perl))) ;for help2man (build-system gnu-build-system) (home-page "https://www.gnu.org/software/datamash/") (synopsis "Scriptable statistics and data calculation") (description "Perform basic numeric, textual and statistical operations on plain text files. Designed to work within standard pipelines without additional code.") (license gpl3+))) t' value='search'/>
AgeCommit message (Expand)Author
2020-01-16publish: Export 'signed-string'....Ludovic Courtès
2019-11-23tests: Use (ice-9 threads)....Ludovic Courtès
2019-06-02publish: '--compression' can be repeated....Ludovic Courtès
2019-05-27publish: Add support for lzip....Ludovic Courtès
2019-05-26publish: Maintain a hash-part-to-store-item mapping in cache....Ludovic Courtès
2019-01-09Remove most uses of the _IO*F constants....Ludovic Courtès
2018-12-17publish: Add a 'Cache-Control' header on /nar responses....Ludovic Courtès
2018-09-04Switch to Guile-Gcrypt....Ludovic Courtès
2018-03-22publish: Always build a new derivation for the "/log/NAME" test....Ludovic Courtès
2018-03-22publish: Add test for non-GET queries....Ludovic Courtès