;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2014, 2018 Eric Bavier ;;; Copyright © 2016, 2017 Efraim Flashner ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages datamash) #:use-module (guix packages) #:use-module (guix licenses) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module (gnu packages) #:use-module (gnu packages perl) #:use-module (gnu packages base)) (define-public datamash (package (name "datamash") (version "1.3") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/datamash/datamash-" version ".tar.gz")) (sha256 (base32 "19jpcv4ryvbz0476d6dgpxpbjkpmih4q84wj06nslls338bm5fzf")) (patches (search-patches "datamash-arm-tests.patch")))) (native-inputs `(("which" ,which) ;for tests ("perl" ,perl))) ;for help2man (build-system gnu-build-system) (home-page "https://www.gnu.org/software/datamash/") (synopsis "Scriptable statistics and data calculation") (description "Perform basic numeric, textual and statistical operations on plain text files. Designed to work within standard pipelines without additional code.") (license gpl3+))) alue=''/>
AgeCommit message (Expand)Author
2021-08-23gnu: python-pygmsh: Update to 7.1.11....Paul Garlick
2021-08-13gnu: python-pygmesh: Update to 7.1.10....Paul Garlick
2021-08-13gnu: python-pygmsh: Change source to 'git-fetch'....Paul Garlick
2021-08-13gnu: python-pygmsh: Update snippet for Gmsh > 4.7.0....Paul Garlick
2021-07-22gnu: Add python-dolfin-adjoint....Paul Garlick
2021-07-12gnu: Add python-pygmsh....Paul Garlick
2021-07-02gnu: Add python-meshio....Paul Garlick
2021-03-17gnu: Use PACKAGE/INHERIT in more places....Mark H Weaver
2020-11-20gnu: fenics: Reduce build time....Maxim Cournoyer