;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2020 Jakub Kądziołka ;;; Copyright © 2020 Tobias Geerinckx-Rice ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages cybersecurity) #:use-module (guix download) #:use-module (guix packages) #:use-module ((guix licenses) #:prefix license:) #:use-module (guix build-system python) #:use-module (gnu packages engineering)) (define-public ropgadget (package (name "ropgadget") (version "6.4") (source (origin (method url-fetch) (uri (pypi-uri "ROPGadget" version)) (sha256 (base32 "1hz6y5a8d4gc2sryz5alpz9mivrk8kj4l3dw00zkz2xca7gwpmsi")))) (build-system python-build-system) (propagated-inputs `(("python-capstone" ,python-capstone))) (home-page "http://shell-storm.org/project/ROPgadget/") (synopsis "Semiautomatic return oriented programming") (description "This tool lets you search for @acronym{ROP, Return Oriented Programming} gadgets in binaries. Some facilities are included for automatically generating chains of gadgets to execute system calls.") (license license:bsd-3))) q' value=''/>
path: root/README
AgeCommit message (Expand)Author
2020-10-23doc: Update README....Maxim Cournoyer
2020-10-22README: Refer to the manual for building from Git....Maxim Cournoyer
2020-06-02doc: Update README to refer to the manual....Ludovic Courtès
2019-11-09doc: Mention value /var to localstatedir option....zimoun
2019-09-04doc: Update 'README'....Ludovic Courtès
2019-01-09build: Require Guile 2.2....Ludovic Courtès
2018-12-02Make Guile-JSON a required dependency....Eric Bavier
2018-11-23Update Guile-SQLite3 URL everywhere....Ludovic Courtès
2018-09-04Switch to Guile-Gcrypt....Ludovic Courtès
2018-06-27doc: Specify Guile-SQLite3 minimum version....Ludovic Courtès
2018-06-14build: Require Guile-SQLite3....Ludovic Courtès
2018-02-26build: Require Guile >= 2.0.13....Ludovic Courtès
2018-01-07doc: Mark zlib as mandatory, libbz2 as optional....Ludovic Courtès
2018-01-01doc: Update requirements in 'README'....Mathieu Lirzin
2017-09-25README: Replace http:// with https:// where applicable.Marius Bakke
2017-03-18build: Require Guile >= 2.0.9....Ludovic Courtès
2017-01-30maint: Fix invalid calls to 'info'....Mathieu Lirzin