;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2019 Nicolas Goaziou ;;; Copyright © 2019 Jesse Gibbons ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages cvassistant) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module ((guix licenses) #:prefix license:) #:use-module (gnu packages qt) #:use-module (gnu packages compression)) (define-public cvassistant (package (name "cvassistant") (version "3.1.0") (source (origin (method url-fetch) (uri (string-append "mirror://sourceforge/cvassistant/" "cvassistant-" version "-src.tar.bz2")) (sha256 (base32 "1y2680bazyiwm50gdhdd4982ckbjscrkbw2mngyk7yw708iadvr7")))) (build-system gnu-build-system) (arguments `(#:phases (modify-phases %standard-phases (add-after 'unpack 'remove-donation-banner ;; Remove dialog box with a donation link, as suggested by ;; the INSTALL file. (lambda _ (substitute* "controllers/mainwindow.cpp" (("//(#define NO_DONATION_PROMPT)" _ line) line)) #t)) (add-after 'unpack 'fix-quazip-directory (lambda _ (substitute* "models/resumedocument.h" (("quazip(/quazipfile\\.h)" _ suffix) (string-append "quazip5" suffix))) #t)) (add-after 'fix-quazip-directory 'fix-quazip-link (lambda _ (substitute* "CVAssistant.pro" (("lquazip-qt5") "lquazip5")) #t)) (add-after 'fix-quazip-directory 'fix-install-root (lambda* (#:key outputs #:allow-other-keys) (let ((out (assoc-ref outputs "out"))) (substitute* "CVAssistant.pro" (("/usr/(bin|share/)" _ suffix) (string-append out "/" suffix))) #t))) (replace 'configure (lambda _ (invoke "qmake")))))) (inputs `(("qtbase" ,qtbase) ("quazip" ,quazip) ("zlib" ,zlib))) (home-page "https://cvassistant.sourceforge.io/") (synopsis "Job application organizer") (description "Whether you're looking for a job or trying to help a friend to find one, CVAssistant is a tool for you. It helps you by preparing resumes and cover letters and organizing your job application process. It: @itemize @item Stores all your skills and experiences. @item Creates resumes tailored for each job you apply. @item Creates cover letters summarized to match each job advertisement. @item Keeps a history of job applications so you are ready when you receive a phone call. @item Writes resumes in your language. All languages are supported! @end itemize") (license license:gpl3+))) ref='#n40'>40 41 42 43 44 45 46 47 48 49 50 51 52 53
A big thanks to Eelco Dolstra, who designed and implemented Nix.
Transposing functional programming discipline to package management
proved to be inspiring and fruitful.

Thanks to the following people who contributed to GNU Guix through
suggestions, bug reports, patches, internationalization, or general
infrastructure help:

	    Lluís Batlle i Rossell <viric@viric.name>
          Sylvain Beucler <beuc@beuc.net>
	   Carlos Carleos <carleos@uniovi.es>
	   Felipe Castro <fefcas@gmail.com>
	   Daniel Clark <dclark@pobox.com>
	Alexandru Cojocaru <xojoc@gmx.com>
	    Aleix Conchillo Flaqué <aconchillo@gmail.com>
          Malcolm Cook <MEC@stowers.org>
           Thomas Danckaert <thomas.danckaert@gmail.com>
	   Rafael Ferreira <rafael.f.f1@gmail.com>
	Christian Grothoff <christian@grothoff.org>
             Eric Hanchrow <eric.hanchrow@gmail.com>
           Konrad Hinsen <konrad.hinsen@fastmail.net>
          Brandon Invergo <brandon@gnu.org>
           Anders Jonsson <anders.jonsson@norsjovallen.se>
	  Jeffrin Jose <ahiliation@yahoo.co.in>
	          Kete <kete@ninthfloor.org>
           Daniel Kochmański <dkochmanski@hellsgate.pl>
	  Matthew Lien <bluet@bluet.org>
             Dave Love <fx@gnu.org>
            Chris Marusich <cmmarusich@gmail.com>
            Niels Möller <nisse@lysator.liu.se>
          Cyprien Nicolas <cyprien@nicolas.tf>
	   Yutaka Niibe <gniibe@fsij.org>
           Andrei Osipov <andrspv@gmail.com>
                  Petter <petter@mykolab.ch>
             Adam Pribyl <pribyl@lowlevel.cz>
            Pjotr Prins <pjotr.public12@thebird.nl>
  Yakkala Yagnesh Raghava <hi@yagnesh.org>
           Joshua Randall <jcrandall@alum.mit.edu>
      Bruno Félix Rezende Ribeiro <oitofelix@gnu.org>
	    Benno Schulenberg <coordinator@translationproject.org>
           Thomas Schwinge <thomas@codesourcery.com>
        Alexander Shendi <Alexander.Shendi@web.de>
	     Alen Skondro <askondro@gmail.com>
              Jan Synáček <jan.synacek@gmail.com>
	 Matthias Wachs <wachs@net.in.tum.de>
Christopher Allan Webber <cwebber@dustycloud.org>
           Philip Woods <elzairthesorcerer@gmail.com>

GNU Guix also includes non-software works.  Thanks to the following
people who contributed the logo and general artwork and themes:

           Nikita Karetnikov <nikita@karetnikov.org>
           Felipe López <felipe.lopez@openmailbox.org>