;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2014 Eric Bavier ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages cursynth) #:use-module (guix packages) #:use-module (guix licenses) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module (gnu packages) #:use-module (gnu packages pkg-config) #:use-module (gnu packages ncurses) #:use-module (gnu packages linux)) (define-public cursynth (package (name "cursynth") (version "1.4") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/cursynth/cursynth-" version ".tar.gz")) (sha256 (base32 "1p9c54v9b0jjx33sammqsdi5xw65csly4cr1i08wv9x6r2yib55m")))) (build-system gnu-build-system) (native-inputs `(("pkg-config" ,pkg-config))) ;; TODO: See https://github.com/iyoko/cursynth/issues/4 which currently ;; prevents us from using pulseaudio (inputs `(("ncurses" ,ncurses) ("alsa" ,alsa-lib))) (home-page "http://www.gnu.org/software/cursynth") (synopsis "Polyphonic and MIDI subtractive music synthesizer using curses") (description "GNU cursynth is a polyphonic synthesizer that runs graphically in the terminal. It is built on a full-featured subtractive synthesis engine. Notes and parameter changes may be entered via MIDI or the computer's keyboard.") (license gpl3+))) 45195ce'>.mailmap
AgeCommit message (Expand)Author
2022-01-11Update mailmap....Leo Famulari
2021-11-06Update mailmap and copyright assignments for Liliana Marie Prikler....Liliana Marie Prikler
2021-09-06Update mailmap....Liliana Marie Prikler
2021-09-04Update mailmap....Marius Bakke
2021-07-27Update mailmap....Leo Famulari
2021-07-08mailmap: Update entries for Matthew James Kraai....Matthew James Kraai
2021-06-23gnu: Add Sollya....Eric Bavier
2021-04-21Update email address for Kei....Kei Kebreau
2020-05-15mailmap: Update for self....Mathieu Othacehe
2020-05-13mailmap: Update entries for Nikita....nikita
2020-03-28Update email address and Savannah handle for Amin Bandali....Amin Bandali
2020-02-09Update e-mail address for Jakob L. Kreuze....Tobias Geerinckx-Rice
2020-01-17Update email address for Amin Bandali....Amin Bandali
2019-12-19Update email for Brett Gilio....Brett Gilio
2019-12-18gnu: leocad: Update to 19.07.1....Eric Bavier