;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2014 David Thompson ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages crypto) #:use-module (gnu packages) #:use-module (guix licenses) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu)) (define-public libsodium (package (name "libsodium") (version "1.0.0") (source (origin (method url-fetch) (uri (string-append "http://download.libsodium.org/libsodium/releases/libsodium-" version ".tar.gz")) (sha256 (base32 "19f9vf0shfp4rc4l791r6xjg06z4i8psj1zkjkm3z5b640yzxlff")))) (build-system gnu-build-system) (synopsis "Portable NaCl-based crypto library") (description "Sodium is a new easy-to-use high-speed software library for network communication, encryption, decryption, signatures, etc.") (license isc) (home-page "http://libsodium.org"))) a5dfb5c330d9ee18668e8c600add19c'/>
AgeCommit message (Expand)Author
2023-10-15gnu: nss: Fix cross-compiling.Efraim Flashner
2023-07-24gnu: nss: Fix building on powerpc-linux.Efraim Flashner
2023-05-07gnu: nss-certs: Update to 3.88.1.Maxim Cournoyer
2023-04-14gnu: nss: Add which to to native inputs and use regular nspr.Maxim Cournoyer
2023-04-14Merge branch 'master' into core-updates.Maxim Cournoyer
2023-03-23Merge remote-tracking branch 'origin/master' into staging.Maxim Cournoyer
2023-03-04gnu: nss: Update to 3.88.1.Ludovic Courtès
2023-03-02Merge remote-tracking branch 'savannah/master' into core-updatesChristopher Baines
2023-02-12gnu: nss: Graft to fix CVE-2023-0767.Tobias Geerinckx-Rice
2023-02-17gnu: nss-next: Update to 3.88.1 [fixes CVE-2023-0767].Maxim Cournoyer
2023-02-13gnu: Add nss-next.Maxim Cournoyer
2023-02-13gnu: Add nspr-next.Maxim Cournoyer
2022-11-20gnu: NSS: Update to 3.85.Marius Bakke
2022-11-20gnu: NSPR: Update to 4.35.Marius Bakke