;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2013 Ludovic Courtès ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages cppi) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module (guix licenses)) (define-public cppi (package (name "cppi") (version "1.18") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/cppi/cppi-" version ".tar.xz")) (sha256 (base32 "1jk42cjaggk71rimjnx3qpmb6hivps0917vl3z7wbxk3i2whb98j")))) (build-system gnu-build-system) (home-page "https://www.gnu.org/software/cppi/") (synopsis "Indent C preprocessor directives to reflect nesting and more") (description "GNU Cppi processes C source code files to properly indent the preprocessor directives to reflect their nesting. It also performs other standardizations, such as correcting the number of spaces between directives and the text following them.") (license gpl3+))) ='grep'>log msg
AgeCommit message (Expand)Author
2019-06-15services: Remove unneeded imports that led to cycles....Ludovic Courtès
2019-05-12services: mcron: Log to a file....Christopher Baines
2019-01-28gnu: Move most packages from guile.scm to new module....Ricardo Wurmus
2019-01-11services: Deprecate a few more service procedures....Ludovic Courtès
2018-11-13services: mcron: Fix typo in comment....Ludovic Courtès
2018-07-13services: mcron: Add 'schedule' action....Ludovic Courtès
2018-03-19gnu: mcron: Update to 1.1 and deprecate "mcron2"....Ludovic Courtès
2017-04-16services: Add a default value to various service types....Ludovic Courtès
2016-06-22services: Add 'mcron-service'....Ludovic Courtès