;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2013 Ludovic Courtès ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages cppi) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module (guix licenses)) (define-public cppi (package (name "cppi") (version "1.18") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/cppi/cppi-" version ".tar.xz")) (sha256 (base32 "1jk42cjaggk71rimjnx3qpmb6hivps0917vl3z7wbxk3i2whb98j")))) (build-system gnu-build-system) (home-page "https://www.gnu.org/software/cppi/") (synopsis "Indent C preprocessor directives to reflect nesting and more") (description "GNU Cppi processes C source code files to properly indent the preprocessor directives to reflect their nesting. It also performs other standardizations, such as correcting the number of spaces between directives and the text following them.") (license gpl3+))) n value='grep'>log msg
AgeCommit message (Expand)Author
2020-08-18gnu: Add flite....Raghav Gururajan
2020-07-29gnu: sphinxbase: Fix building....Efraim Flashner
2020-03-31gnu: sonic: Fix installation directories....Tobias Geerinckx-Rice
2020-03-29gnu: Add pocketsphinx....Nicolas Goaziou
2020-03-29gnu: Add sphinxbase....Nicolas Goaziou
2020-02-24gnu: espeak-ng: Update to 1.50....Marius Bakke
2019-11-13gnu: sonic: Don't use unstable tarball....Efraim Flashner
2019-10-09gnu: espeak: Build with the C++ 98 standard....Marius Bakke
2019-09-18gnu: festival: Fix scripts....Ricardo Wurmus
2019-09-18gnu: festival: Include default voice....Ricardo Wurmus
2019-09-17gnu: festival: Install missing info files....Ricardo Wurmus
2019-09-17gnu: Add festival....Ricardo Wurmus