;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2013 Ludovic Courtès ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages cppi) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module (guix licenses)) (define-public cppi (package (name "cppi") (version "1.18") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/cppi/cppi-" version ".tar.xz")) (sha256 (base32 "1jk42cjaggk71rimjnx3qpmb6hivps0917vl3z7wbxk3i2whb98j")))) (build-system gnu-build-system) (home-page "https://www.gnu.org/software/cppi/") (synopsis "Indent C preprocessor directives to reflect nesting and more") (description "GNU Cppi processes C source code files to properly indent the preprocessor directives to reflect their nesting. It also performs other standardizations, such as correcting the number of spaces between directives and the text following them.") (license gpl3+))) ' value='965f6d74acb591c8ab1efe23a737a52011ba885a'/>
AgeCommit message (Expand)Author
2024-01-19gnu: nsq: Fix build on i686-linux....Sharlatan Hellseher
2024-01-18gnu: pacemaker: Update to 2.1.7....Sharlatan Hellseher
2024-01-18gnu: corosync: Update to 3.1.8....Sharlatan Hellseher
2024-01-18gnu: nsq: Update to 1.3.0....Sharlatan Hellseher
2024-01-18gnu: kronosnet: Update to 1.28....Sharlatan Hellseher
2024-01-18gnu: libqb: Update to 2.0.8....Sharlatan Hellseher
2024-01-18gnu: haproxy: Update to 2.9.0....Sharlatan Hellseher
2024-01-03gnu: go-github-com-julienschmidt-httprouter: Move to (gnu packages golang-web)....Sharlatan Hellseher
2023-09-04gnu: Add nsq....Sharlatan Hellseher
2023-07-16gnu: libqb: Tweak description....Tobias Geerinckx-Rice
2023-07-16gnu: libqb: Update to 2.0.7....Tobias Geerinckx-Rice
2023-07-16gnu: libqb: Fix cross-compilation....Tobias Geerinckx-Rice
2023-07-16gnu: libqb: Remove obsolete bootstrapping inputs....Tobias Geerinckx-Rice
2023-04-09gnu: haproxy: Update to 2.7.6....Yovan Naumovski
2023-03-26gnu: haproxy: Move to (gnu packages high-availability)....Sharlatan Hellseher