;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2013 Ludovic Courtès ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages cppi) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module (guix licenses)) (define-public cppi (package (name "cppi") (version "1.18") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/cppi/cppi-" version ".tar.xz")) (sha256 (base32 "1jk42cjaggk71rimjnx3qpmb6hivps0917vl3z7wbxk3i2whb98j")))) (build-system gnu-build-system) (home-page "https://www.gnu.org/software/cppi/") (synopsis "Indent C preprocessor directives to reflect nesting and more") (description "GNU Cppi processes C source code files to properly indent the preprocessor directives to reflect their nesting. It also performs other standardizations, such as correcting the number of spaces between directives and the text following them.") (license gpl3+))) g
AgeCommit message (Expand)Author
2020-01-23gnu: mes: Update to 0.22....Jan Nieuwenhuizen
2019-12-07gnu: Add mes-rb5....Jan Nieuwenhuizen
2019-12-07gnu: mes: Add patch to remove store name from binary....Jan Nieuwenhuizen
2019-11-25gnu: mes: Update to 0.21....Jan Nieuwenhuizen
2019-11-14gnu: Add m2-planet....Jan Nieuwenhuizen
2019-10-12gnu: mescc-tools: Use 'git-fetch'....Ludovic Courtès
2019-09-29bootstrap: mes: Add mes-0.19....Jan Nieuwenhuizen
2019-09-29bootstrap: mescc-tools: Use mescc-tools-0.5.2, mescc-tools....Jan Nieuwenhuizen
2019-09-17Merge branch 'master' into core-updatesLudovic Courtès
2019-09-09gnu: mes: Update to 0.20....Jan Nieuwenhuizen
2019-09-09gnu: mescc-tools: Update to 0.6.1....Jan Nieuwenhuizen
2019-09-09gnu: nyacc: Update to 0.99.0....Jan Nieuwenhuizen
2019-06-13Merge branch 'master' into core-updatesLudovic Courtès
2019-06-13gnu: nyacc: Add 0.94.0....Ludovic Courtès
2019-05-25Merge branch 'staging' into core-updatesMarius Bakke
2019-05-21gnu: mes: Prepare for non-x86 architectures....Danny Milosavljevic