;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2013 Ludovic Courtès ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages cppi) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module (guix licenses)) (define-public cppi (package (name "cppi") (version "1.18") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/cppi/cppi-" version ".tar.xz")) (sha256 (base32 "1jk42cjaggk71rimjnx3qpmb6hivps0917vl3z7wbxk3i2whb98j")))) (build-system gnu-build-system) (home-page "http://www.gnu.org/software/cppi/") (synopsis "Indent C preprocessor directives to reflect nesting and more") (description "GNU Cppi processes C source code files to properly indent the preprocessor directives to reflect their nesting. It also performs other standardizations, such as correcting the number of spaces between directives and the text following them.") (license gpl3+))) '>log msg
AgeCommit message (Expand)Author
2016-12-13gnu: nano: Update to 2.7.2....Tobias Geerinckx-Rice
2016-11-13Merge branch 'core-updates'Ludovic Courtès
2016-11-07gnu: nano: Update to 2.7.1....Efraim Flashner
2016-09-30Merge branch 'master' into core-updatesLudovic Courtès
2016-09-28gnu: Add and use gettext-minimal....Alex Kost
2016-09-04gnu: nano: Update to 2.7.0....Rene Saavedra
2016-03-04gnu: nano: Update to 2.5.3....Ludovic Courtès
2016-02-15gnu: nano: Update to 2.5.2....Efraim Flashner
2016-01-24gnu: nano: Update to 2.5.1....Efraim Flashner
2015-12-06gnu: nano: Update to 2.5.0....Efraim Flashner
2015-11-21gnu: nano: Update to 2.4.3....Efraim Flashner
2015-07-21gnu: nano: Update to 2.4.2....Ludovic Courtès
2015-04-18gnu: nano: Update to 2.4.1....Andreas Enge
2015-03-26gnu: nano: Update to 2.4.0....Ludovic Courtès
2014-07-23gnu: nano: Upgrade to 2.3.6....Andreas Enge