;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2012 Nikita Karetnikov ;;; Copyright © 2014 Mark H Weaver ;;; Copyright © 2020 Marius Bakke ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages cpio) #:use-module (guix licenses) #:use-module (gnu packages) #:use-module (gnu packages autotools) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu)) (define-public cpio (package (name "cpio") (version "2.13") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/cpio/cpio-" version ".tar.bz2")) (sha256 (base32 "0vbgnhkawdllgnkdn6zn1f56fczwk0518krakz2qbwhxmv2vvdga")) (modules '((guix build utils))) (snippet '(begin ;; Remove superfluous declaration that trips GCC 10. (substitute* "src/global.c" (("char \\*program_name;") "")))))) (build-system gnu-build-system) (home-page "https://www.gnu.org/software/cpio/") (synopsis "Manage cpio and tar file archives") (description "GNU cpio copies files into or out of cpio or tar archives. Indeed, many formats are supported, including legacy formats. The format is determined automatically by the program and is handled appropriately. Furthermore, the location of the archive is not important. It can be another file on the drive, a tape, or data on a pipe.") (license gpl3+))) ages/mes.scm
AgeCommit message (Expand)Author
2019-10-12gnu: mescc-tools: Use 'git-fetch'....Ludovic Courtès
2019-09-29bootstrap: mes: Add mes-0.19....Jan Nieuwenhuizen
2019-09-29bootstrap: mescc-tools: Use mescc-tools-0.5.2, mescc-tools....Jan Nieuwenhuizen
2019-09-17Merge branch 'master' into core-updatesLudovic Courtès
2019-09-09gnu: mes: Update to 0.20....Jan Nieuwenhuizen
2019-09-09gnu: mescc-tools: Update to 0.6.1....Jan Nieuwenhuizen
2019-09-09gnu: nyacc: Update to 0.99.0....Jan Nieuwenhuizen
2019-06-13Merge branch 'master' into core-updatesLudovic Courtès
2019-06-13gnu: nyacc: Add 0.94.0....Ludovic Courtès
2019-05-25Merge branch 'staging' into core-updatesMarius Bakke
2019-05-21gnu: mes: Prepare for non-x86 architectures....Danny Milosavljevic