;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2012 Nikita Karetnikov ;;; Copyright © 2014 Mark H Weaver ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages cpio) #:use-module (guix licenses) #:use-module (gnu packages) #:use-module (gnu packages autotools) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu)) (define-public cpio (package (name "cpio") (version "2.12") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/cpio/cpio-" version ".tar.bz2")) (sha256 (base32 "0vi9q475h1rki53100zml75vxsykzyhrn70hidy41s5c2rc8r6bh")) (patches (search-patches "cpio-CVE-2016-2037.patch")))) (build-system gnu-build-system) (home-page "https://www.gnu.org/software/cpio/") (synopsis "Manage cpio and tar file archives") (description "GNU cpio copies files into or out of cpio or tar archives. Indeed, many formats are supported, including legacy formats. The format is determined automatically by the program and is handled appropriately. Furthermore, the location of the archive is not important. It can be another file on the drive, a tape, or data on a pipe.") (license gpl3+))) h' size='10' name='q' value=''/>
AgeCommit message (Expand)Author
2019-12-07system: Remove custom 'config-file service from "vm-image.tmpl"....Ludovic Courtès
2019-05-16vm-image: Remove ModemManager....Ludovic Courtès
2019-05-16vm-image: Remove 'network-manager-applet' from system profile....Ludovic Courtès
2019-05-01vm-image: Add 'label' field....Ludovic Courtès
2019-04-28vm-image: Add 'nss-certs' to the global package set....Ludovic Courtès
2019-04-27vm-image: Allow for password-less sudo....Ludovic Courtès
2019-04-27vm-image: Mention 'info guix' in the MOTD....Ludovic Courtès
2019-04-27vm-image: Add a font to the global profile....Ludovic Courtès
2019-04-27doc: Update bit about SSH in the VM....Ludovic Courtès
2019-04-26vm-image: Remove NetworkManager & co. and add the DHCP client....Ludovic Courtès
2019-04-26vm-image: Use the actual file name of the current file....Ludovic Courtès
2019-04-26system: Provide a new VM image configuration....Ludovic Courtès
2019-03-13Remove traces of "GuixSD"....Ludovic Courtès
2019-01-23gnu: Replace all cons* with beginner-friendly (append (list ...))....Pierre Neidhardt