;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2012 Nikita Karetnikov ;;; Copyright © 2014 Mark H Weaver ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages cpio) #:use-module (guix licenses) #:use-module (gnu packages) #:use-module (gnu packages autotools) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu)) (define-public cpio (package (name "cpio") (version "2.12") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/cpio/cpio-" version ".tar.bz2")) (sha256 (base32 "0vi9q475h1rki53100zml75vxsykzyhrn70hidy41s5c2rc8r6bh")) (patches (search-patches "cpio-CVE-2016-2037.patch")))) (build-system gnu-build-system) (home-page "https://www.gnu.org/software/cpio/") (synopsis "Manage cpio and tar file archives") (description "GNU cpio copies files into or out of cpio or tar archives. Indeed, many formats are supported, including legacy formats. The format is determined automatically by the program and is handled appropriately. Furthermore, the location of the archive is not important. It can be another file on the drive, a tape, or data on a pipe.") (license gpl3+)))
AgeCommit message (Expand)Author
2018-05-17Merge branch 'master' into core-updatesMark H Weaver
2018-05-17gnu: libfm: Update to 1.3.0.2....Tobias Geerinckx-Rice
2018-04-30Merge branch 'master' into core-updatesMark H Weaver
2018-04-27gnu: pcmanfm: Update to 1.3.0....Tobias Geerinckx-Rice
2018-04-27gnu: libfm: Update to 1.3.0....Tobias Geerinckx-Rice
2018-03-27gnu: Use invoke and return #t from all builders....Mark H Weaver
2018-03-20Merge branch 'master' into core-updatesMark H Weaver
2018-03-20Correct name and Email for ng0....ng0
2018-03-16gnu: All snippets report errors using exceptions, else return #t....Mark H Weaver
2018-01-18gnu: lxterminal: Update to 0.3.1....Tobias Geerinckx-Rice
2018-01-16gnu: lxde: Use HTTPS for lxde.org home pages....Tobias Geerinckx-Rice
2017-11-23gnu: pcmanfm: Fix CVE-2017-8934....Brendan Tildesley
2017-11-23gnu: pcmanfm: Add missing inputs. Remove comment....Brendan Tildesley