;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2020 Leo Prikler ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages convmv) #:use-module (gnu packages) #:use-module (gnu packages perl) #:use-module (guix licenses) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu)) (define-public convmv (package (name "convmv") (version "2.05") (source (origin (method url-fetch) (uri (string-append "https://www.j3e.de/linux/convmv/convmv-" version ".tar.gz")) (sha256 (base32 "19hwv197p7c23f43vvav5bs19z9b72jzca2npkjsxgprwj5ardjk")))) (build-system gnu-build-system) (arguments `(#:test-target "test" #:make-flags `(,(string-append "PREFIX=" (assoc-ref %outputs "out"))) #:phases (modify-phases %standard-phases (delete 'bootstrap) (delete 'configure) (add-before 'check 'unpack-testsuite (lambda _ (invoke "tar" "xf" "testsuite.tar") (patch-shebang "suite/dotests.sh") (patch-shebang "suite/parsable_tester.pl") #t))))) (inputs `(("perl" ,perl))) (synopsis "Convert filenames between character sets") (description "convmv is a file renamer, that converts between different encodings, e.g. from ISO-8859-1 to UTF-8. It is particularly usefuls for files with names, that display incorrectly.") (license (list gpl2 gpl3)) (home-page "https://www.j3e.de/"))) bbc5'/>
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2024-05-28 15:26:07 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:45:26 +0200
commit102a3a3a048aa6e01c6410ca073752eae7bdbbc5 (patch)
tree40cd2be42d52938274f93ede6ed6b60103fb8f33 /gnu
parentf16db7fd1bd325375b7ea064166e4314ea6e8a61 (diff)
downloadguix-102a3a3a048aa6e01c6410ca073752eae7bdbbc5.tar.gz
guix-102a3a3a048aa6e01c6410ca073752eae7bdbbc5.zip
gnu: Add texlive-cjkutils-bin.
* gnu/packages/tex.scm (texlive-cjkutils-bin): New variable. (texlive-cjkutils)[propagated-inputs]: Add TEXLIVE-CJKUTILS-BIN. Change-Id: I0790442c9295a00fdb7024d844a75dcac2f9ad3a
Diffstat (limited to 'gnu')