;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2013 Ludovic Courtès ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages cflow) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module (guix licenses) #:use-module (gnu packages emacs)) (define-public cflow (package (name "cflow") (version "1.4") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/cflow/cflow-" version ".tar.bz2")) (sha256 (base32 "1jkbq97ajcf834z68hbn3xfhiz921zhn39gklml1racf0kb3jzh3")))) (build-system gnu-build-system) (home-page "http://www.gnu.org/software/cflow/") (synopsis "Create a graph of control flow within a program") (description "cflow analyzes C source files and produces a graph charting the control flow of the program. It can output the graph in several styles and in either the POSIX format or in an extended GNU format. cflow also includes a major mode for Emacs for examining the flowcharts that it produces.") (license gpl3+))) '>committer
AgeCommit message (Expand)Author
2024-02-13gnu: go-golang-org-x-sys: Move to golang-build....Sharlatan Hellseher
2024-02-05gnu: mbedtls-apache: Rename to mbedtls-lts....Hilton Chain
2023-10-22gnu: go-github-com-stretchr-testify: Move to (gnu packages golang-check)....Sharlatan Hellseher
2023-10-17gnu: irssi: Update to 1.4.5....André Batista
2023-09-10gnu: glirc: Re-indent....Tobias Geerinckx-Rice
2023-09-10gnu: Add glirc-lua....Tobias Geerinckx-Rice
2023-08-23gnu: weechat: Update to 4.0.4....Michael Ford
2023-08-23gnu: sic: Update to 1.3....Michael Ford
2023-08-18gnu: Add snuik....Janneke Nieuwenhuizen
2023-07-30gnu: catgirl: Use G-expressions....Tobias Geerinckx-Rice
2023-07-30gnu: catgirl: Update to 2.2....Tobias Geerinckx-Rice
2023-07-30gnu: catgirl: Don't use snapshot tarball....Tobias Geerinckx-Rice
2023-07-30gnu: glirc: Extend description....Tobias Geerinckx-Rice
2023-07-30gnu: glirc: Install man page and README.md....Tobias Geerinckx-Rice
2023-07-30gnu: Remove duplicate module import from (gnu packages irc)....Tobias Geerinckx-Rice
2023-07-23gnu: Add glirc....Tobias Geerinckx-Rice
2023-07-28gnu: weechat: Update to 4.0.2....fanquake