;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2015 Andreas Enge ;;; Copyright © 2015 Mark H Weaver ;;; Copyright © 2016, 2017 Ludovic Courtès ;;; Copyright © 2017 Leo Famulari ;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see
aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-01-20 17:11:41 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-01-20 17:19:04 +0100
commitba6210fa6d04e752a4ea0a0c8b57d35403e06d2a (patch)
tree9cee3ef0f5a9163ea7a78bda409fc5414afad8b8 /gnu
parenta8ee51a215b12d79857bbfca5cc9a3865cf470e0 (diff)
downloadguix-ba6210fa6d04e752a4ea0a0c8b57d35403e06d2a.tar.gz
guix-ba6210fa6d04e752a4ea0a0c8b57d35403e06d2a.zip
gnu: r-blme: Update to 1.0-5.
* gnu/packages/cran.scm (r-blme): Update to 1.0-5.
Diffstat (limited to 'gnu')
ymbolic links for and by openssl ;; Strangely, the call (system* "c_rehash" certsdir) ;; from inside the build dir fails with ;; "Usage error; try -help." ;; This looks like a bug in openssl-1.0.2, but we can also ;; switch into the target directory. (invoke "c_rehash" ".")) #t)))))) (synopsis "CA certificates from Mozilla") (description "This package provides certificates for Certification Authorities (CA) taken from the NSS package and thus ultimately from the Mozilla project.") (home-page "https://developer.mozilla.org/en-US/docs/Mozilla/Projects/NSS") (license license:mpl2.0))) (define-public le-certs (package (name "le-certs") (version "0") (source #f) (build-system trivial-build-system) (arguments '(#:modules ((guix build utils)) #:builder (begin (use-modules (guix build utils)) (let ((root (assoc-ref %build-inputs "isrgrootx1.pem")) (intermediate (assoc-ref %build-inputs "letsencryptauthorityx3.pem")) (backup (assoc-ref %build-inputs "letsencryptauthorityx4.pem")) (out (string-append (assoc-ref %outputs "out") "/etc/ssl/certs")) (openssl (assoc-ref %build-inputs "openssl")) (perl (assoc-ref %build-inputs "perl"))) (mkdir-p out) (for-each (lambda (cert) (copy-file cert (string-append out "/" (strip-store-file-name cert)))) (list root intermediate backup)) ;; Create hash symlinks suitable for OpenSSL ('SSL_CERT_DIR' and ;; similar.) (chdir (string-append %output "/etc/ssl/certs")) (invoke (string-append perl "/bin/perl") (string-append openssl "/bin/c_rehash") "."))))) (native-inputs `(("openssl" ,openssl) ("perl" ,perl))) ;for 'c_rehash' (inputs `(; The Let's Encrypt root certificate, "ISRG Root X1". ("isrgrootx1.pem" ,(origin (method url-fetch) (uri "https://letsencrypt.org/certs/isrgrootx1.pem") (sha256 (base32 "0zycy85ff9ga53z1q03df89ka9iihb9p8bjhw056rq2y4rn3b6ac")))) ;; "Let’s Encrypt Authority X3", the active Let's Encrypt intermediate ;; certificate. ("letsencryptauthorityx3.pem" ,(origin (method url-fetch) (uri "https://letsencrypt.org/certs/letsencryptauthorityx3.pem") (sha256 (base32 "1kvac1dhm1d02bhrfj6l1cz1dpldz6ishb78zzvy8245zgvh7pdn")))) ;; "Let’s Encrypt Authority X4", the backup Let's Encrypt intermediate ;; certificate. This will be used for disaster recovery and will only be ;; used should Let's Encrypt lose the ability to issue with "Let’s ;; Encrypt Authority X3". ("letsencryptauthorityx4.pem" ,(origin (method url-fetch) (uri "https://letsencrypt.org/certs/letsencryptauthorityx4.pem") (sha256 (base32 "0giiixknr0mls2ir6qqzb42mq7x9a7vz79gbn7fjszbf87pqhpzm")))))) (home-page "https://letsencrypt.org/certificates/") (synopsis "Let's Encrypt root and intermediate certificates") (description "This package provides a certificate store containing only the Let's Encrypt root and intermediate certificates. It is intended to be used within Guix.") (license license:public-domain)))