;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2014 Eric Bavier ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages ccache) #:use-module (guix packages) #:use-module ((guix licenses) #:select (gpl3+)) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module (gnu packages) #:use-module (gnu packages perl) #:use-module (gnu packages compression)) (define-public ccache (package (name "ccache") (version "3.1.10") (source (origin (method url-fetch) (uri (string-append "https://www.samba.org/ftp/ccache/ccache-" version ".tar.xz")) (sha256 (base32 "0mr8n1nbykxw4rs55ad8wd6xmfhihn09mxpxb91sn9mlsd1ryhw8")))) (build-system gnu-build-system) (native-inputs `(("perl" ,perl))) ;for test.sh (inputs `(("zlib" ,zlib))) (arguments '(#:phases (alist-cons-before 'check 'patch-test-shebangs (lambda _ (substitute* '("test/test_hashutil.c" "test.sh") (("#!/bin/sh") (string-append "#!" (which "sh"))))) %standard-phases))) (home-page "https://ccache.samba.org/") (synopsis "Compiler cache") (description "Ccache is a compiler cache. It speeds up recompilation by caching previous compilations and detecting when the same compilation is being done again. Supported languages are C, C++, Objective-C and Objective-C++.") (license gpl3+))) f='/guix/log/gnu?id=311e627c3e73f8e12f354144e450ff8198fd274b'>gnu/build/linux-modules.scm
AgeCommit message (Expand)Author
2021-12-16linux-modules: Ignore EINVAL in ‘modprobe’ mode....Tobias Geerinckx-Rice via Guix-patches via
2020-08-25linux-libre: Support module compression....Mathieu Othacehe
2020-03-22system: Add kernel-loadable-modules to operating-system....Danny Milosavljevic
2019-08-16linux-modules: Define and use a module name database....Ludovic Courtès
2019-08-16linux-modules: Add 'load-linux-modules-from-directory'....Ludovic Courtès
2019-08-16linux-modules: Add "modules.devname" writer....Ludovic Courtès
2019-08-16linux-modules: Add "modules.alias" writer....Danny Milosavljevic
2019-03-13linux-modules: Factorize 'missing-modules'....Ludovic Courtès
2019-03-05linux-modules: module-soft-dependencies: Partition the result and return it a......Danny Milosavljevic
2019-01-25linux-modules: module-soft-dependencies: Remove colon from section names....Danny Milosavljevic
2019-01-25linux-modules: Add module-soft-dependencies....Danny Milosavljevic