;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2014, 2015, 2016, 2018 Eric Bavier ;;; Copyright © 2016, 2017 Efraim Flashner ;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages ccache) #:use-module (guix packages) #:use-module ((guix licenses) #:select (gpl3+)) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module (gnu packages) #:use-module (gnu packages perl) #:use-module (gnu packages compression)) (define-public ccache (package (name "ccache") (version "3.7.11") (source (origin (method url-fetch) (uri (string-append "https://github.com/ccache/ccache/releases/download/v" version "/ccache-" version ".tar.xz")) (sha256 (base32 "0s1g0ylrayzax68xlqnxx46f5bhvr2pcm1yzswmj0kcs14404icd")))) (build-system gnu-build-system) (native-inputs `(("perl" ,perl) ; for test/run ("which" ,(@ (gnu packages base) which)))) (inputs `(("zlib" ,zlib))) (arguments '(#:phases (modify-phases %standard-phases (add-before 'check 'setup-tests (lambda _ (substitute* '("unittest/test_hashutil.c" "test/suites/base.bash") (("#!/bin/sh") (string-append "#!" (which "sh")))) #t))))) (home-page "https://ccache.dev/") (synopsis "Compiler cache") (description "Ccache is a compiler cache. It speeds up recompilation by caching previous compilations and detecting when the same compilation is being done again. Supported languages are C, C++, Objective-C and Objective-C++.") (license gpl3+))) d7f5813109444e'>containers.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-12-23 19:06:47 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-12-23 19:06:47 +0100
commitef060487a21833f097485b583fd7f5813109444e (patch)
tree67d57c1ead734f41d367d2d28074f2e78febae0d /gnu/packages/containers.scm
parenta3c26687885305a6a9fda3aef3c66a9fcc962e67 (diff)
downloadguix-ef060487a21833f097485b583fd7f5813109444e.tar.gz
guix-ef060487a21833f097485b583fd7f5813109444e.zip
gnu: naev: Update to 0.10.0.
* gnu/packages/games.scm (naev): Update to 0.10.0. [inputs]: Add ENET, PCRE2.
Diffstat (limited to 'gnu/packages/containers.scm')
0 files changed, 0 insertions, 0 deletions