/gnu/packages/bootstrap/

dden' name='showmsg' value='1'/> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/tests/cve.scm
2018-06-22
AgeCommit message (Collapse)Author
2016-05-28cve: Use a more compact format for the list of package/versions.Ludovic Courtès
On a warm cache, "guix lint -c cve vorbis-tools" goes down from 6.5s to 2.4s. * guix/cve.scm (cpe->package-name): Change to return two values instead of a pair. (cpe->product-alist): New procedure. (%parse-vulnerability-feed): Use it instead of 'filter-map'. (fetch-vulnerabilities): Bump sexp format version to 1. (vulnerabilities->lookup-proc): Adjust accordingly. When #:version is omitted, return a list of vulnerabilities instead of a list of version/vulnerability pairs. * tests/cve.scm (%expected-vulnerabilities) ("vulnerabilities->lookup-proc): Adjust accordingly.
gnu: doxygen: Update to 1.8.14....Danny Milosavljevic
2018-06-08gnu: doxygen: Work around GCC ICE on armhf-linux....Ludovic Courtès
2018-03-25gnu: asciidoc: Restore custom 'bootstrap' phase....Mark H Weaver
2018-03-11build-system/gnu: Add 'bootstrap' phase....Ludovic Courtès
2018-02-09Merge branch 'master' into core-updatesMark H Weaver
2018-02-06gnu: asciidoc: Update to 8.6.10....Tobias Geerinckx-Rice
2017-11-11gnu: doxygen: Build with flex@2.6.1....Efraim Flashner
2017-08-29Update e-mail for Kei Kebreau....Kei Kebreau
2017-06-20gnu: Move contents of zip module into compression module....Arun Isaac