;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2012, 2013, 2015 Ludovic Courtès ;;; Copyright © 2018 Tobias Geerinckx-Rice ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages bison) #:use-module (guix licenses) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module (gnu packages m4) #:use-module (gnu packages perl) #:use-module (gnu packages flex) #:use-module (srfi srfi-1)) (define-public bison (package (name "bison") (version "3.0.5") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/bison/bison-" version ".tar.xz")) (sha256 (base32 "0f7kjygrckkx8vas2nm673592jif0a9mw5g8207f6hj6h4pfyp07")))) (build-system gnu-build-system) (native-inputs `(("perl" ,perl) ;; m4 is not present in PATH when cross-building. ("m4" ,m4))) (inputs `(("flex" ,flex))) (propagated-inputs `(("m4" ,m4))) (home-page "https://www.gnu.org/software/bison/") (synopsis "Parser generator") (description "GNU Bison is a general-purpose parser generator. It can build a deterministic or generalized LR parser from an annotated, context-free grammar. It is versatile enough to have many applications, from parsers for simple tools through complex programming languages.") (license gpl3+))) g-daemon.ac?id=6f93b525d3159675478c78541c95452d1b12e5a3'>config-daemon.ac
AgeCommit message (Expand)Author
2018-12-04build: Default to https://ci.guix.info for substitutes....Ludovic Courtès
2018-11-14daemon: Install 'authenticate' script under LIBEXECDIR/guix....Ludovic Courtès
2018-09-06build: Remove -L flag when $LIBGCRYPT_LIBDIR is empty....Ludovic Courtès
2018-03-05build: Default to berlin.guixsd.org substitutes on aarch64....Ludovic Courtès
2018-03-05build: Always use https substitute URLs....Ludovic Courtès
2018-02-27build: Really build 'guix offload' when possible....Ludovic Courtès
2018-02-26build: Require Guile >= 2.0.13....Ludovic Courtès
2018-01-07daemon: Make libbz2 an optional dependency....Ludovic Courtès
2018-01-07daemon: Add gzip log compression....Ludovic Courtès
2017-02-06config-daemon.ac: detect host AR...Sergei Trofimovich
2016-11-25offload: Use Guile-SSH instead of GNU lsh....Ludovic Courtès
2016-11-16daemon: Add "builtin:download" derivation builder....Ludovic Courtès