;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2012, 2013, 2015 Ludovic Courtès ;;; Copyright © 2018 Tobias Geerinckx-Rice ;;; Copyright © 2019 Efraim Flashner ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages bison) #:use-module (guix licenses) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module (gnu packages m4) #:use-module (gnu packages perl) #:use-module (gnu packages flex) #:use-module (srfi srfi-1)) (define-public bison (package (name "bison") (version "3.3.2") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/bison/bison-" version ".tar.xz")) (sha256 (base32 "016qp59wxakz3ckxwyrmzxk406q0h286ydz8ww1m0pnrc5dy97h3")))) (build-system gnu-build-system) (native-inputs `(("perl" ,perl) ;; m4 is not present in PATH when cross-building. ("m4" ,m4))) (inputs `(("flex" ,flex))) (propagated-inputs `(("m4" ,m4))) (home-page "https://www.gnu.org/software/bison/") (synopsis "Parser generator") (description "GNU Bison is a general-purpose parser generator. It can build a deterministic or generalized LR parser from an annotated, context-free grammar. It is versatile enough to have many applications, from parsers for simple tools through complex programming languages.") (license gpl3+))) 20ce4061a007e1ef8035c3be27879'>gnu/packages/polkit.scm
AgeCommit message (Expand)Author
2022-09-08Merge branch 'staging' into core-updatesMarius Bakke
2022-09-06gnu: polkit: Look up polkit rules under /etc, and enable session tracking....Marius Bakke
2022-08-30gnu: Remove needless export....Marius Bakke
2022-08-30gnu: Remove unused module import....Marius Bakke
2022-08-30gnu: polkit: Fix cross-compilation....Marius Bakke
2022-08-30gnu: polkit: Fix build....Marius Bakke
2022-08-28gnu: polkit-mozjs: Rename to polkit and remove obsolete polkit-duktape....Maxim Cournoyer
2022-08-27gnu: polkit: Update to 121....Marius Bakke
2022-08-27gnu: mozjs: Update to 102.2.0....Marius Bakke
2022-07-20gnu: polkit-mozjs: Fix native-inputs on stage....Jean-Pierre De Jesus DIAZ
2022-06-16gnu: polkit-qt: Update to 1-0.114.0....Efraim Flashner
2022-06-01Merge remote-tracking branch 'origin/master' into stagingEfraim Flashner