#! @PYTHON@
# -*- mode: python -*-
import glob
import os
import sys
import warnings
def __renpy_files(directory):
for pattern in ['*.rpa', '*.rpyc', '*.rpy']:
for file in glob.iglob(pattern, root_dir=directory):
yield file
def path_to_gamedir(basedir, name):
candidates = [name, 'game', 'data', 'launcher/game']
if __renpy_files(basedir):
return basedir
for candidate in candidates:
gamedir = os.path.join(basedir, candidate)
if __renpy_files(gamedir):
return gamedir
return basedir
def path_to_common(renpy_base):
return renpy_base + "/common"
def path_to_saves(gamedir, save_directory=None):
import renpy
if save_directory is None:
save_directory = renpy.config.save_directory
save_directory = renpy.exports.fsencode(save_directory)
if not save_directory:
return gamedir + "/saves"
return os.path.join(os.path.expanduser("~/.renpy"), save_directory)
def main():
try:
import renpy.bootstrap
import renpy.arguments
except ImportError:
print("""Could not import renpy.bootstrap.
Please ensure you decompressed Ren'py correctly, preserving the directory
structure.""", file=sys.stderr)
raise
args = renpy.arguments.bootstrap()
if not args.basedir:
print("""This Ren'py requires a basedir to launch.
The basedir is the directory, in which .rpy source files or compiled .rpyc files
live -- usually the 'game' subdirectory of a game packaged by Ren'py.
If you want the Ren'py launcher, use \"renpy-launcher\" instead.""",
file=sys.stderr)
sys.exit()
renpy.bootstrap.bootstrap("@RENPY_BASE@")
if __name__ == "__main__":
main()
ame='qt'>
build-system: Add pyproject-build-system....This is an experimental build system based on python-build-system
that implements PEP 517-compliant builds.
* doc/guix.texi (Build Systems): Add pyproject-build-system section.
* doc/contributing.texi (Python Modules): Mention pyproject.toml and the
PYTHON-TOOLCHAIN package, as well as differences to python-build-system.
* guix/build-system/pyproject.scm,
guix/build/pyproject-build-system.scm,
gnu/packages/aux-files/python/sanity-check-next.py,
gnu/packages/python-commencement.scm: New files.
* Makefile.am (MODULES): Register the new build systems.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add python-commencement.scm.
* gnu/packages/python.scm (python-sans-pip, python-sans-pip-wrapper): New
variables.
Co-authored-by: Marius Bakke <marius@gnu.org>
Lars-Dominik Braun
2022-10-27
gnu: pypy: Move to separate module....This removes the need to import (gnu packages python-xyz) in (gnu packages
python), avoiding issues with circular imports.
* gnu/packages/python.scm (pypy): Move…
* gnu/packages/pypy.scm (pypy): …here
* gnu/local.mk: Register new file.
Co-authored-by: Marius Bakke <marius@gnu.org>
Lars-Dominik Braun
2022-10-13
gnu: micropython: Update to 1.19....* gnu/packages/python.scm (micropython): Update to 1.19.
v2 adds my copyright declaration. thnx!
Signed-off-by: Christopher Baines <mail@cbaines.net>
jgart
2022-09-07
gnu: pypy: Fix build....This fixes a regression that was introduced in commit 553c009d741.
* gnu/packages/python.scm (pypy)[phases]{install}: Rename the OUT variable to
#$OUTPUT.
Maxim Cournoyer
2022-08-30
gnu: Introduce versioned 'openssl-1.1' variable.......and use it in packages that do not yet support 3.0.
* gnu/packages/tls.scm (openssl): Rename to ...
(openssl-1.1): ... this.
(openssl/fixed): Inherit from OPENSSL-1.1.
(openssl-3.0): Likewise.
(openssl): Turn into alias for OPENSSL-1.1.
* gnu/packages/ruby.scm (ruby-2.6)[inputs]: Change from OPENSSL to OPENSSL-1.1.
(ruby-3.0)[inputs]: Change "openssl" input to OPENSSL.
(ruby-3.1): Inherit from RUBY-3.0.
* gnu/packages/python.scm (python-2.7)[inputs]: Change from OPENSSL to
OPENSSL-1.1.
(python-3.9)[inputs]: Replace "openssl" with OPENSSL.
* gnu/packages/python-crypto.scm (python-cryptography)[inputs]: Change from
OPENSSL to OPENSSL-1.1.
* gnu/packages/databases.scm (mariadb)[inputs]: Likewise.
* gnu/packages/node.scm (node)[native-inputs, inputs]: Likewise.
(node-lts)[native-inputs]: Likewise.