;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2014 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages autogen)
  #:use-module (guix packages)
  #:use-module (guix licenses)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages)
  #:use-module (gnu packages perl)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages base)
  #:use-module (gnu packages guile))

(define-public autogen
  (package
    (name "autogen")
    (version "5.18.16")
    (source
     (origin
       (method url-fetch)
       (uri (string-append "mirror://gnu/autogen/rel" version
                           "/autogen-" version ".tar.xz"))
       (sha256
        (base32 "16mlbdys8q4ckxlvxyhwkdnh1ay9f6g0cyp1kylkpalgnik398gq"))))
    (build-system gnu-build-system)
    (native-inputs `(("pkg-config" ,pkg-config)
                     ("which" ,which)))
    (inputs `(("guile" ,guile-2.2)
              ("perl" ,perl)))          ; for doc generator mdoc
    (arguments
     '(#:configure-flags
       ;; XXX Needed to build 5.18.16.  ./configure fails without it:
       ;; “Something went wrong bootstrapping makefile fragments for
       ;;  automatic dependency tracking.  Try re-running configure with […]”
       (list "--disable-dependency-tracking")

       ;; XXX: Parallel tests may cause an indefinite hang with GNU Make 4.3.
       #:parallel-tests? #f

       #:phases
       (modify-phases %standard-phases
         (add-before 'patch-source-shebangs 'patch-test-scripts
           (lambda _
             (let ((sh (which "sh")))
               (substitute*
                   (append (find-files "agen5/test" "\\.test$")
                           (find-files "autoopts/test" "\\.(test|in)$"))
                 (("/bin/sh") sh))
               #t))))))
    (home-page "https://www.gnu.org/software/autogen/")
    (synopsis "Automated program generator")
    (description
     "AutoGen is a program to ease the maintenance of programs that contain
large amounts of repetitive text.  It automates the construction of these
sections of the code, simplifying the task of keeping the text in sync.  It
also includes an add-on package called AutoOpts, which is specialized for the
maintenance and documentation of program options.")
    (license gpl3+)))
arius Bakke</td></tr>
<tr><td><span title='2022-07-23 19:43:10 +0200'>2022-07-23</span></td><td><a href='/guix/commit/gnu/packages/cyrus-sasl.scm?id=1ecf710caed394e066aa0e5a74aa5128d777a329'>gnu: cyrus-sasl: Fix indentation.</a><span class='msg-avail'>...<span class='msg-tooltip'>* gnu/packages/cyrus-sasl.scm (cyrus-sasl): Reindent.
</span></span></td><td>Marius Bakke</td></tr>
<tr><td><span title='2022-07-23 19:43:10 +0200'>2022-07-23</span></td><td><a href='/guix/commit/gnu/packages/cyrus-sasl.scm?id=093f13610bf50762040696b320b69f6e9376ef34'>gnu: cyrus-sasl: Update to 2.1.28.</a><span class='msg-avail'>...<span class='msg-tooltip'>* gnu/packages/cyrus-sasl.scm (cyrus-sasl): Update to 2.1.28.
[source](uri): Use new download location.
[source](patches): Remove.
[native-inputs]: Remove.
[arguments]: Remove #:phases.  Use G-expression.
* gnu/packages/patches/cyrus-sasl-CVE-2019-19906.patch,
gnu/packages/patches/cyrus-sasl-ac-try-run-fix.patch: Delete files.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
</span></span></td><td>Marius Bakke</td></tr>
<tr><td><span title='2021-12-13 17:48:25 +0100'>2021-12-13</span></td><td><a href='/guix/commit/gnu/packages/cyrus-sasl.scm?id=8394619baceb118df92e355377fd543bb1aa501a'>gnu: Simplify package inputs.</a><span class='msg-avail'>...<span class='msg-tooltip'>This commit was obtained by running:

  ./pre-inst-env guix style

without any additional argument.
</span></span></td><td>Ludovic Courtès</td></tr>
<tr><td><span title='2021-04-16 16:57:28 -0400'>2021-04-16</span></td><td><a href='/guix/commit/gnu/packages/cyrus-sasl.scm?id=0f7e1eed16dbe56e5873a7fdfbda514f488867ff'>gnu: cyrus-sasl: Absorb grafted replacement.</a><span class='msg-avail'>...<span class='msg-tooltip'>* gnu/packages/cyrus-sasl.scm (cyrus-sasl)[source]: Use
cyrus-sasl-CVE-2019-19906.patch.
[replacement]: Remove field.
(cyrus-sasl/fixed): Remove variable.
</span></span></td><td>Leo Famulari</td></tr>
<tr><td><span title='2021-03-15 12:22:17 +0100'>2021-03-15</span></td><td><a href='/guix/commit/gnu/packages/cyrus-sasl.scm?id=8a085c178095d0ed204b6263deb6fc275b651ee1'>gnu: cyrus-sasl/fixed: Make private.</a><span class='msg-avail'>...<span class='msg-tooltip'>* gnu/packages/cyrus-sasl.scm (cyrus-sasl/fixed): Use define instead of
define-public.
</span></span></td><td>Léo Le Bouter</td></tr>
<tr><td><span title='2021-03-10 11:51:09 +0100'>2021-03-10</span></td><td><a href='/guix/commit/gnu/packages/cyrus-sasl.scm?id=70128b8afacf332b0aff69ebcad6868fd158e8ad'>gnu: cyrus-sasl: Fix CVE-2019-19906.</a><span class='msg-avail'>...<span class='msg-tooltip'>* gnu/packages/patches/cyrus-sasl-CVE-2019-19906.patch: New patch.
* gnu/local.mk (dist_patch_DATA): Register it.
* gnu/packages/cyrus-sasl.scm (cyrus-sasl/fixed): New variable. Apply patch.
(cyrus-sasl)[replacement]: Graft.
</span></span></td><td>Léo Le Bouter</td></tr>