;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2013 Ludovic Courtès ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages aspell) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module (guix licenses) #:use-module (gnu packages perl)) (define-public aspell (package (name "aspell") (version "0.60.6.1") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/aspell/aspell-" version ".tar.gz")) (sha256 (base32 "1qgn5psfyhbrnap275xjfrzppf5a83fb67gpql0kfqv37al869gm")))) (build-system gnu-build-system) (inputs `(("perl" ,perl))) (home-page "http://aspell.net/") (synopsis "Spell checker") (description "GNU Aspell is a free spell checker designed to eventually replace Ispell. It can either be used as a library or as an independent spell checker. Its main feature is that it does a superior job of suggesting possible replacements for a misspelled word than just about any other spell checker out there for the English language. Unlike Ispell, Aspell can also easily check documents in UTF-8 without having to use a special dictionary. Aspell will also do its best to respect the current locale setting. Other advantages over Ispell include support for using multiple dictionaries at once and intelligently handling personal dictionaries when more than one Aspell process is open at once.") (license lgpl2.1+))) nu?id=4b81d5c4bc442a12c681586f6c25a4ca0af44056'>gnu/packages/javascript.scm
AgeCommit message (Expand)Author
2018-10-30gnu: mujs: Install shared library....Efraim Flashner
2018-10-30gnu: mujs: Update to 1.0.5....Efraim Flashner
2018-08-30gnu: mujs: Update to 1.0.4....Tobias Geerinckx-Rice
2018-05-17Merge branch 'master' into core-updatesMark H Weaver
2018-05-11gnu: Add js-filesaver....Nicolas Goaziou
2018-04-10Merge branch 'master' into core-updatesMark H Weaver
2018-04-02gnu: mujs: Update to 1.0.3....Marius Bakke
2018-03-27gnu: Use invoke and return #t from all builders....Mark H Weaver
2017-12-27gnu: mujs: Update to 1.0.2....Marius Bakke
2017-11-12gnu: Add mujs....Efraim Flashner