;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2013 Nikita Karetnikov ;;; Copyright © 2014, 2015 Mark H Weaver ;;; Copyright © 2017, 2019 Efraim Flashner ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages apl) #:use-module (guix licenses) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module (gnu packages gettext) #:use-module (gnu packages maths) #:use-module (gnu packages pcre) #:use-module (gnu packages readline) #:use-module (gnu packages sqlite)) (define-public apl (package (name "apl") (version "1.8") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/apl/apl-" version ".tar.gz")) (sha256 (base32 "1jxvv2h3y1am1fw6r5sn3say1n0dj8shmscbybl0qhqdia2lqkql")))) (build-system gnu-build-system) (home-page "https://www.gnu.org/software/apl/") (inputs `(("gettext" ,gettext-minimal) ("lapack" ,lapack) ("pcre" ,pcre2) ("sqlite" ,sqlite) ("readline" ,readline))) (arguments `(#:configure-flags (list (string-append "--with-sqlite3=" (assoc-ref %build-inputs "sqlite"))))) (synopsis "APL interpreter") (description "GNU APL is a free interpreter for the programming language APL. It is an implementation of the ISO standard 13751.") (license gpl3+))) 26ce9a08920eebaa48d0ad27b'>gnu/packages/disk.scm
AgeCommit message (Expand)Author
2020-11-19gnu: Don't append '.git' to GitHub uris....Efraim Flashner
2020-11-17gnu: python-parted: Update to 3.11.7....Tobias Geerinckx-Rice
2020-11-07gnu: duperemove: Correctly report version....Tobias Geerinckx-Rice
2020-11-07gnu: f3: Update to 8.0....Tobias Geerinckx-Rice
2020-11-07gnu: f3: Fix cross-compilation....Tobias Geerinckx-Rice
2020-11-07gnu: duperemove: Update to 0.11.2....Tobias Geerinckx-Rice
2020-11-07gnu: duperemove: Prepare for cross-compilation....Tobias Geerinckx-Rice
2020-10-16gnu: ndctl: Update to 70.1....Tobias Geerinckx-Rice
2020-10-06gnu: memkind: Declare a source file-name....Efraim Flashner
2020-10-06gnu: Add memkind....Danny Milosavljevic
2020-09-23gnu: Fix typoes in package descriptions....Tobias Geerinckx-Rice