;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2013 Nikita Karetnikov ;;; Copyright © 2014 Mark H Weaver ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages apl) #:use-module (guix licenses) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module (gnu packages gettext) #:use-module (gnu packages maths) #:use-module (gnu packages databases) #:use-module (gnu packages readline)) (define-public apl (package (name "apl") (version "1.4") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/apl/apl-" version ".tar.gz")) (sha256 (base32 "0fl9l4jb5wpnb54kqkphavi657z1cv15h9qj2rqy2shf33dk3nk9")))) (build-system gnu-build-system) (home-page "http://www.gnu.org/software/apl/") (inputs `(("gettext" ,gnu-gettext) ("lapack" ,lapack) ("sqlite" ,sqlite) ("readline" ,readline))) (arguments `(#:configure-flags (list (string-append "--with-sqlite3=" (assoc-ref %build-inputs "sqlite"))))) (synopsis "APL interpreter") (description "GNU APL is a free interpreter for the programming language APL. It is an implementation of the ISO standard 13751.") (license gpl3+))) search'/>
AgeCommit message (Expand)Author
2022-08-14gnu: noise-suppression-for-voice: Rename from ‘rnnoise’.Tobias Geerinckx-Rice
2022-08-14gnu: noisetorch: Update to 0.12.2.Tobias Geerinckx-Rice
2022-07-24gnu: pamixer: Update to 1.6.Tobias Geerinckx-Rice
2022-07-24gnu: paprefs: Update to 1.2.Tobias Geerinckx-Rice
2022-05-31gnu: Remove pulseaudio-dlna.Maxim Cournoyer
2021-12-29gnu: Remove leftover libsndfile/fixed package.Leo Famulari
2021-12-13gnu: Further simplify package inputs.Ludovic Courtès
2021-12-13gnu: Simplify package inputs.Ludovic Courtès
2021-11-11gnu: pulseaudio: Add doxygen to fix build.Maxim Cournoyer
2021-11-11gnu: pulseaudio: Update to 15.0.Brice Waegeneire
2021-11-11gnu: pulseaudio: Use meson build system.Brice Waegeneire
2021-11-11gnu: pulseaudio: Update to 14.2.Brice Waegeneire
2021-11-03Merge remote-tracking branch 'origin/master' into core-updates-frozenEfraim Flashner
2021-11-03gnu: pavucontrol: Update to 5.0.Tobias Geerinckx-Rice
2021-11-03gnu: pamixer: Update to 1.5.Tobias Geerinckx-Rice
2021-10-02gnu: Update gtkmm to 4.2.0, add gtkmm@3, and adjust gtkmm@2.Raghav Gururajan
2021-08-01Merge branch 'master' into core-updates-frozenMarius Bakke
2021-07-30gnu: Add libsndfile/fixed.Ricardo Wurmus