;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2013 Nikita Karetnikov ;;; Copyright © 2014, 2015 Mark H Weaver ;;; Copyright © 2017, 2019 Efraim Flashner ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages apl) #:use-module (guix licenses) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module (gnu packages gettext) #:use-module (gnu packages maths) #:use-module (gnu packages pcre) #:use-module (gnu packages readline) #:use-module (gnu packages sqlite)) (define-public apl (package (name "apl") (version "1.8") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/apl/apl-" version ".tar.gz")) (sha256 (base32 "1jxvv2h3y1am1fw6r5sn3say1n0dj8shmscbybl0qhqdia2lqkql")))) (build-system gnu-build-system) (home-page "https://www.gnu.org/software/apl/") (inputs `(("gettext" ,gettext-minimal) ("lapack" ,lapack) ("pcre" ,pcre2) ("sqlite" ,sqlite) ("readline" ,readline))) (arguments `(#:configure-flags (list (string-append "--with-sqlite3=" (assoc-ref %build-inputs "sqlite"))))) (synopsis "APL interpreter") (description "GNU APL is a free interpreter for the programming language APL. It is an implementation of the ISO standard 13751.") (license gpl3+))) amp;showmsg=1'>root/gnu/home.scm
AgeCommit message (Collapse)Author
2023-03-20home: 'home-environment-with-provenance' uses the HE location info.Sergey Trofimov
* gnu/home.scm (home-environment-with-provenance): Make `config-file` optional, with the default taken from the HE location info. Signed-off-by: Andrew Tropin <andrew@trop.in>
2023-03-13home: Export home-environment-packages.Sergey Trofimov
* gnu/home.scm (home-environment-packages): Export procedure. Signed-off-by: Andrew Tropin <andrew@trop.in>
2022-08-19home: Fix docstring.Andrew Tropin
gnu/home.scm (home-environment-derivation): Fix docstring.
2022-08-01home: Add 'home-generation-base'.Ludovic Courtès
This reverts commit 670818a4049edb8a77a5b596fbc7558bde57165c, thereby reinstating 5df8f7802e8b45855e8f84830677001dc631e4f7. * gnu/home.scm (%profile-generation-rx): New variable. (home-generation-base): New procedure.
2022-07-17Revert "home: Add 'home-generation-base'."Tobias Geerinckx-Rice
This reverts commit 5df8f7802e8b45855e8f84830677001dc631e4f7. This commit or the next one appears to have broken ‘guix pull’.
2022-07-23home: Add 'home-generation-base'.Ludovic Courtès
* gnu/home.scm (%profile-generation-rx): New variable. (home-generation-base): New procedure.
2021-12-19home: Add gexp-compiler for home-environments.Andrew Tropin
* gnu/home.scm (home-environment-compiler): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>