;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2013 Nikita Karetnikov ;;; Copyright © 2014, 2015 Mark H Weaver ;;; Copyright © 2017 Efraim Flashner ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages apl) #:use-module (guix licenses) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module (gnu packages gettext) #:use-module (gnu packages maths) #:use-module (gnu packages databases) #:use-module (gnu packages readline)) (define-public apl (package (name "apl") (version "1.7") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/apl/apl-" version ".tar.gz")) (sha256 (base32 "07xq8ddlmz8psvsmwr23gar108ri0lwmw0n6kpxcv8ypas1f5xlg")))) (build-system gnu-build-system) (home-page "https://www.gnu.org/software/apl/") (inputs `(("gettext" ,gettext-minimal) ("lapack" ,lapack) ("sqlite" ,sqlite) ("readline" ,readline))) (arguments `(#:configure-flags (list (string-append "--with-sqlite3=" (assoc-ref %build-inputs "sqlite"))))) (synopsis "APL interpreter") (description "GNU APL is a free interpreter for the programming language APL. It is an implementation of the ISO standard 13751.") (license gpl3+))) 7a'>root/gnu/packages/gtk.scm
AgeCommit message (Expand)Author
2021-05-18gnu: perl-cairo: Update to 1.109....Efraim Flashner
2021-05-08gnu: volctl: Comment on the license....Ludovic Courtès
2021-05-08gnu: Add volctl....Simon Streit
2021-04-29Merge remote-tracking branch 'origin/master' into wip-ungraftingLudovic Courtès
2021-04-26gnu: gtkdatabox: Adjust source URL....Lars-Dominik Braun
2021-04-20gnu: gtkdatabox: Update to 1.0.0....Tobias Geerinckx-Rice
2021-04-16gnu: cairo: Absorb grafted replacement....Leo Famulari
2021-04-16gnu: gdk-pixbuf: Absorb grafted replacement....Leo Famulari
2021-04-10gnu: Fix typo in (gnu packages gtk)....Tobias Geerinckx-Rice
2021-03-27gnu: Use 'gtk-doc/stable' in native-inputs of selected packages....Mark H Weaver
2021-03-27gnu: gtk-doc: Add 'gtk-doc/stable' variant....Mark H Weaver
2021-03-22gnu: gtk-layer-shell: Update to 0.6.0....Léo Le Bouter
2021-03-19gnu: Add dragon-drop....Yoav Marco
2021-03-12gnu: cairo: Fix CVE-2018-19876 and CVE-2020-35492....Mark H Weaver
2021-03-12gnu: gdk-pixbuf: Fix CVE-2020-29385....Mark H Weaver
2021-03-11gnu: libdatrie: Update to 0.2.13....Tobias Geerinckx-Rice
2021-02-19gnu: Add GtkDatabox....Leo Famulari