;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2014 John Darringon ;;; Copyright © 2016, 2020, 2021 Efraim Flashner ;;; Copyright © 2017 Hartmut Goebel ;;; Copyright © 2018, 2019, 2022 Tobias Geerinckx-Rice ;;; Copyright © 2019 Guillaume Le Vaillant ;;; Copyright © 2020 Leo Famulari ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages aidc) #:use-module (gnu packages) #:use-module (guix gexp) #:use-module ((guix licenses) #:prefix license:) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix git-download) #:use-module (gnu packages autotools) #:use-module (gnu packages check) #:use-module (gnu packages imagemagick) #:use-module (gnu packages gettext) #:use-module (gnu packages glib) #:use-module (gnu packages gtk) #:use-module (gnu packages image) #:use-module (gnu packages perl) #:use-module (gnu packages pkg-config) #:use-module (gnu packages python) #:use-module (gnu packages python-xyz) #:use-module (gnu packages pretty-print) #:use-module (gnu packages qt) #:use-module (gnu packages video) #:use-module (guix build-system cmake) #:use-module (guix build-system gnu)) (define-public zxing-cpp ;; Use the master branch as it includes unreleased build system improvements ;; allowing to use system libraries (instead of attempting to fetch them ;; from the Internet). (let ((revision "0") (commit "00783db7aa3bcf8620a301854ac71c0ceaaca0c1")) (package (name "zxing-cpp") (version (git-version "1.2.0" revision commit)) (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/nu-book/zxing-cpp") (commit commit))) (file-name (git-file-name name version)) (sha256 (base32 "1yl2cpaqiv1g4nq9v0xfj1vd5faz55k4541vz6hsffvcxgn9nmc5")))) (build-system cmake-build-system) (native-inputs (list fmt-8 googletest)) (synopsis "C++ port of ZXing") (description "ZXing-CPP is a barcode scanning library.") (home-page "https://github.com/nu-book/zxing-cpp") (license license:asl2.0)))) ;;; This older variant is kept for gst-plugins-bad (see: ;;; https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad/-/issues/1684). (define-public zxing-cpp-1.2 (package/inherit zxing-cpp (name "zxing-cpp") (version "1.2.0") (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/nu-book/zxing-cpp") (commit (string-append "v" version)))) (file-name (git-file-name name version)) (sha256 (base32 "1gjj9c7h634rrmmgzbc7cxjqsxdq0paj6113k02ncjm1s9abk7ik")))) ;; Disable tests to avoid bundled dependencies. (arguments '(#:tests? #f #:configure-flags '("-DBUILD_BLACKBOX_TESTS=OFF"))) (native-inputs '()))) (define-public barcode (package (name "barcode") (version "0.99") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/barcode/barcode-" version ".tar.xz")) (sha256 (base32 "1indapql5fjz0bysyc88cmc54y8phqrbi7c76p71fgjp45jcyzp8")))) (build-system gnu-build-system) (arguments ;; Fix build with GCC 10. '(#:configure-flags '("CFLAGS=-fcommon"))) (synopsis "Convert text strings to printed bars in various standards") (description "GNU Barcode is a flexible tool to produce printed barcodes from text strings. It supports a variety of encoding standards and sizing measurements. Barcodes can be output in PostScript or Encapsulated PostScript formats.") (license license:gpl3+) (home-page "https://www.gnu.org/software/barcode/"))) (define-public qrencode (package (name "qrencode") (version "4.1.1") (source (origin (method url-fetch) (uri (string-append "https://fukuchi.org/works/qrencode/" "qrencode-" version ".tar.bz2"))
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
-;;; Copyright © 2013, 2014, 2015, 2016, 2017, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013, 2014, 2015, 2016, 2019 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014, 2017 Eric Bavier <bavier@member.fsf.org>
@@ -1990,6 +1990,28 @@ between Julian dates and Gregorian dates.")
(define-public python2-jdcal
(package-with-python2 python-jdcal))
+(define-public python-jsondiff
+ (package
+ (name "python-jsondiff")
+ (version "1.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "jsondiff" version))
+ (sha256
+ (base32
+ "00v3689175aqzdscrxpffm712ylp8jvcpqdg51ca22ni6721p51l"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-nose" ,python-nose)
+ ("python-nose-random" ,python-nose-random)))
+ (home-page
+ "https://github.com/fzumstein/jsondiff")
+ (synopsis "Compare JSON and JSON-like structures in Python")
+ (description "@code{jsondiff} is a Python library which lets you
+compare, diff, and patch JSON and JSON-like structures in Python.")
+ (license license:expat)))
+
(define-public python-jsonschema
(package
(name "python-jsonschema")
@@ -2922,6 +2944,27 @@ for SSH and SFTP. It has the following main usages:
@end itemize")
(license license:asl2.0)))
+(define-public python-rstr
+ (package
+ (name "python-rstr")
+ (version "2.2.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "rstr" version))
+ (sha256
+ (base32
+ "197dw8mbq0pjjz1l6h1ksi62vgn7x55d373ch74y06744qiq5sjx"))))
+ (build-system python-build-system)
+ (home-page
+ "http://bitbucket.org/leapfrogdevelopment/rstr/overview")
+ (synopsis "Generate random strings in Python")
+ (description "This package provides a python module for generating
+random strings of various types. It could be useful for fuzz testing,
+generating dummy data, or other applications. It has no dependencies
+outside the standard library.")
+ (license license:bsd-3)))
+
(define-public python-scp
(package
(name "python-scp")
@@ -6716,14 +6759,14 @@ Python.")
(define-public python-markdown
(package
(name "python-markdown")
- (version "3.1.1")
+ (version "3.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "Markdown" version))
(sha256
(base32
- "0yhylk4ffqqs7x086fav4pnfsl1021v7lghznzkififprmmqfl1f"))))
+ "1gwqrhrp0n9xllgmjc8n1p260968kr0dd2jncjkj4r617q61imss"))))
(build-system python-build-system)
(native-inputs
`(("python-nose" ,python-nose)
@@ -6735,10 +6778,21 @@ Python.")
Markdown. The library features international input, various Markdown
extensions, and several HTML output formats. A command line wrapper
markdown_py is also provided to convert Markdown files to HTML.")
+ (properties `((python2-variant . ,(delay python2-markdown))))
(license license:bsd-3)))