;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2015, 2016 Leo Famulari ;;; Copyright © 2020 Björn Höfling ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages abduco) #:use-module (guix build-system gnu) #:use-module (guix utils) #:use-module (guix download) #:use-module (guix licenses) #:use-module (guix packages)) (define-public abduco (package (name "abduco") (version "0.6") (source (origin (method url-fetch) (uri (string-append "https://www.brain-dump.org/projects/abduco/abduco-" version ".tar.gz")) (sha256 (base32 "1x1m58ckwsprljgmdy93mvgjyg9x3cqrzdf3mysp0mx97zhhj2f9")))) (build-system gnu-build-system) (arguments `(#:make-flags (list (string-append "CC=" ,(cc-for-target)) (string-append "PREFIX=" (assoc-ref %outputs "out"))) #:phases (modify-phases %standard-phases (delete 'configure) (delete 'check)))) ; no test suite (synopsis "Session management in a clean and simple way") (description "abduco provides session management i.e. it allows programs to be run independently from their controlling terminal. That is, programs can be detached---run in the background---and then later reattached.") (home-page "https://www.brain-dump.org/projects/abduco/") (license isc))) a href='/guix/log/gnu?id=8f0069170c261642fd0b3128c3eb194e4ba2efca'>gnu/packages/wicd.scm
AgeCommit message (Expand)Author
2016-11-29gnu: wicd: Fix build....Hartmut Goebel
2016-09-28gnu: Add and use gettext-minimal....Alex Kost
2016-04-14gnu: packages: Use 'search-patches' everywhere....Alex Kost
2016-04-01gnu: wicd: Add template for WPA2-TTLS....Ludovic Courtès
2016-04-01gnu: wicd: Update to 1.7.4....Ludovic Courtès
2015-10-11gnu: wicd: Install 'index.theme' file in the right place....宋文武
2015-08-29gnu: Use 'install-file' instead of 'mkdir-p' and 'copy-file' in obvious cases....Ludovic Courtès
2015-08-12gnu: wicd: Fix bugs in curses interface program....Mark H Weaver
2015-05-23gnu: dbus-glib: Propagate inputs dbus and glib....Andreas Enge
2015-05-09gnu: wicd: Add patch to fix template instantiation....Ludovic Courtès
2015-02-06gnu: wicd: Fix curses client to work with urwid 1.3....Mark H Weaver
2015-02-05gnu: wicd: Allow wicd-gtk to find its icons....Mark H Weaver
2015-02-04gnu: Add wicd....Mark H Weaver