;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2015, 2016 Leo Famulari ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages abduco) #:use-module (guix build-system gnu) #:use-module (guix download) #:use-module (guix licenses) #:use-module (guix packages)) (define-public abduco (package (name "abduco") (version "0.6") (source (origin (method url-fetch) (uri (string-append "http://www.brain-dump.org/projects/abduco/abduco-" version ".tar.gz")) (sha256 (base32 "1x1m58ckwsprljgmdy93mvgjyg9x3cqrzdf3mysp0mx97zhhj2f9")))) (build-system gnu-build-system) (arguments `(#:make-flags (list "CC=gcc" (string-append "PREFIX=" (assoc-ref %outputs "out"))) #:phases (modify-phases %standard-phases (delete 'configure) (delete 'check)))) ; no test suite (synopsis "Session management in a clean and simple way") (description "abduco provides session management i.e. it allows programs to be run independently from their controlling terminal. That is, programs can be detached---run in the background---and then later reattached.") (home-page "http://www.brain-dump.org/projects/abduco/") (license isc))) mit' value='search'/>
AgeCommit message (Expand)Author
2018-03-25gnu: ruby-ffi: Update to 1.9.23....Tobias Geerinckx-Rice
2018-02-26gnu: python-cffi: Update phase style....Tobias Geerinckx-Rice
2018-02-26gnu: python-cffi: Update to 1.11.4....Tobias Geerinckx-Rice
2018-02-26gnu: ruby-ffi: Update to 1.9.22....Tobias Geerinckx-Rice
2017-11-17gnu: Move testing packages from python.scm to check.scm....Ricardo Wurmus
2017-10-15gnu: ruby-ffi: Move to libffi.scm....Efraim Flashner
2017-10-15gnu: python-cffi: Move to libffi.scm...Efraim Flashner
2017-04-13gnu: libffi: Fix builds on Alpha....Sergei Trofimovich
2017-04-02gnu: Use HTTPS URLs for GitHub home-pages....Leo Famulari
2016-01-06gnu: libffi: Update to 3.2.1....Efraim Flashner