;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2015, 2016 Leo Famulari ;;; Copyright © 2020 Björn Höfling ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages abduco) #:use-module (guix build-system gnu) #:use-module (guix utils) #:use-module (guix download) #:use-module (guix licenses) #:use-module (guix packages)) (define-public abduco (package (name "abduco") (version "0.6") (source (origin (method url-fetch) (uri (string-append "https://www.brain-dump.org/projects/abduco/abduco-" version ".tar.gz")) (sha256 (base32 "1x1m58ckwsprljgmdy93mvgjyg9x3cqrzdf3mysp0mx97zhhj2f9")))) (build-system gnu-build-system) (arguments `(#:make-flags (list (string-append "CC=" ,(cc-for-target)) (string-append "PREFIX=" (assoc-ref %outputs "out"))) #:phases (modify-phases %standard-phases (delete 'configure) (delete 'check)))) ; no test suite (synopsis "Session management in a clean and simple way") (description "abduco provides session management i.e. it allows programs to be run independently from their controlling terminal. That is, programs can be detached---run in the background---and then later reattached.") (home-page "https://www.brain-dump.org/projects/abduco/") (license isc))) t/gnu/packages/cmake.scm
AgeCommit message (Expand)Author
2020-01-12gnu: cmake@3.15.5: Honor 'SSL_CERT_DIR' and 'SSL_CERT_FILE'....Ludovic Courtès
2020-01-12gnu: cmake@3.15.5: Apply "cmake-curl-certificates.patch"....Ludovic Courtès
2019-11-15gnu: CMake: Add version 3.15.5....Ivan Vilata-i-Balaguer
2019-09-17Merge branch 'master' into core-updatesLudovic Courtès
2019-09-11gnu: cmake: Add package variant that knows about X.509 certificates....Ludovic Courtès
2019-08-01gnu: emacs-cmake-mode: Do not inherit inputs and outputs from CMake....Marius Bakke
2019-07-31gnu: CMake: Update to 3.15.1....Marius Bakke
2019-06-15gnu: CMake: Update to 3.14.5....Marius Bakke
2019-05-25gnu: cmake: Update to 3.14.4....Marius Bakke
2019-05-25Merge branch 'staging' into core-updatesMarius Bakke
2019-05-04gnu: CMake: Update to 3.14.3....Marius Bakke
2019-03-20cmake: Generate documentation....Maxim Cournoyer
2019-03-17gnu: cmake: Update to 3.14.0....Marius Bakke
2019-02-09gnu: cmake: Try CPATH and C_INCLUDE_PATH when finding system libraries....Marius Bakke
2018-12-12gnu: CMake: Update to 3.13.1....Marius Bakke