;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2015, 2016 Leo Famulari ;;; Copyright © 2020 Björn Höfling ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages abduco) #:use-module (guix build-system gnu) #:use-module (guix utils) #:use-module (guix download) #:use-module (guix licenses) #:use-module (guix packages)) (define-public abduco (package (name "abduco") (version "0.6") (source (origin (method url-fetch) (uri (string-append "https://www.brain-dump.org/projects/abduco/abduco-" version ".tar.gz")) (sha256 (base32 "1x1m58ckwsprljgmdy93mvgjyg9x3cqrzdf3mysp0mx97zhhj2f9")))) (build-system gnu-build-system) (arguments `(#:make-flags (list (string-append "CC=" ,(cc-for-target)) (string-append "PREFIX=" (assoc-ref %outputs "out"))) #:phases (modify-phases %standard-phases (delete 'configure) (delete 'check)))) ; no test suite (synopsis "Session management in a clean and simple way") (description "abduco provides session management i.e. it allows programs to be run independently from their controlling terminal. That is, programs can be detached---run in the background---and then later reattached.") (home-page "https://www.brain-dump.org/projects/abduco/") (license isc))) >
AgeCommit message (Collapse)Author
2021-06-05gnu: ispell: Update to 3.4.04.Tobias Geerinckx-Rice
* gnu/packages/aspell.scm (ispell): Update to 3.4.04.
2021-06-02gnu: ispell: Update to 3.4.03.Tobias Geerinckx-Rice
* gnu/packages/aspell.scm (ispell): Update to 3.4.03.
2021-05-182020-01-23tests: Fix typo in comment.Ludovic Courtès
* gnu/tests.scm: Add missing word in commentary.
2019-12-18gexp: Allow character literals in GEXP->SEXP.Marius Bakke
Fixes <https://bugs.gnu.org/38628>. * tests/gexp.scm ("lower-gexp, character literal"): New test. * guix/gexp.scm (gexp->sexp)[self-quoting?]: Add CHAR? to the tested types. * guix/repl.scm (self-quoting?): Likewise. * gnu/tests.scm (marionette-shepherd-service)[self-quoting?]: Likewise.
* gnu/packages/aspell.scm (aspell-dict-ro): New variable. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
2021-01-12gnu: ispell: Update to 3.4.02.Tobias Geerinckx-Rice
* gnu/packages/aspell.scm (ispell): Update to 3.4.02.
2021-01-06gnu: ispell: Update to 3.4.01.Tobias Geerinckx-Rice
* gnu/packages/aspell.scm (ispell): Update to 3.4.01.