;; This is a Guix channel. (channel (version 0) (news-file "etc/news.scm") (keyring-reference "keyring") (url "https://git.savannah.gnu.org/git/guix.git")) ;the primary URL ortcut icon' href='/cgit-static/favicon.ico'/>
aboutsummaryrefslogtreecommitdiff
path: root/tests/containers.scm
AgeCommit message (Collapse)Author
2020-10-01linux-container: Reset jailed root permissions.Jelle Licht
* gnu/build/linux-container.scm (mount-file-systems): Add 'chmod' call. * tests/containers.scm ("call-with-container, mnt namespace, root permissions"): New test.
2019-10-15tests: Skip container test when lacking kernel support.Ludovic Courtès
This is a followup to 96b35998e610c7fc37bf87bf9e07e63d3bebd0a3. * tests/containers.scm ("eval/container, non-empty load path"): Add missing 'skip-if-unsupported' call.
2019-09-18linux-container: 'eval/container' correctly passes -L and -C flags.Ludovic Courtès
This fixes a type error. * gnu/system/linux-container.scm (eval/container): Use 'append-map', not 'map'. * tests/containers.scm ("eval/container, non-empty load path"): New test.
2019-07-19linux-container: Add 'eval/container'.Ludovic Courtès
* gnu/system/linux-container.scm (eval/container): New procedure. * tests/containers.scm ("eval/container, exit status") ("eval/container, writable user mapping"): New tests.
2019-04-02linux-container: Make the guest UID and GID a parameter.Ludovic Courtès
* gnu/build/linux-container.scm (initialize-user-namespace): Add #:guest-uid and #:guest-gid parameters and honor them. (run-container): Likewise. (call-with-container): Likewise. * tests/containers.scm ("call-with-container, user namespace, guest UID/GID"): New test.
2017-05-31tests: Fix race condition in 'container-excursion*' test.Ludovic Courtès
* tests/containers.scm ("container-excursion*"): Move (namespace pid) call before (kill pid SIGKILL).