From 2b371f4dd5ddafa0786240b40408ef5c30d7a526 Mon Sep 17 00:00:00 2001
From: Efraim Flashner <efraim@flashner.co.il>
Date: Wed, 20 Feb 2019 09:05:30 +0200
Subject: gnu: Don't use the store path in the .desktop file.

This fixes bug#30228.

* gnu/packages/sync.scm (owncloud-client)[arguments]: Add a custom phase
to substitute the executable name for the full path to the binary.
Remove the 'patch-dot-desktop-files phase.
---
 gnu/packages/sync.scm | 8 +++++++-
 1 file changed, 7 insertions(+), 1 deletion(-)

(limited to 'gnu')

diff --git a/gnu/packages/sync.scm b/gnu/packages/sync.scm
index df9f3b0e16..450e7b767a 100644
--- a/gnu/packages/sync.scm
+++ b/gnu/packages/sync.scm
@@ -79,7 +79,13 @@
              (substitute* "test/CMakeLists.txt"
                           (("owncloud_add_test\\(Utility \"\"\\)" test)
                            (string-append "#" test)))
-             #t)))
+             #t))
+         (add-after 'unpack 'dont-embed-store-path
+           (lambda _
+             (substitute* "src/common/utility_unix.cpp"
+               (("QCoreApplication::applicationFilePath\\()") "\"owncloud\""))
+             #t))
+         (delete 'patch-dot-desktop-files))
        #:configure-flags '("-DUNIT_TESTING=ON"
                            ;; build without qtwebkit, which causes the
                            ;; package to FTBFS while looking for QWebView.
-- 
cgit v1.2.3