From b998d582218a9c35828f138cde9da5a2e8fdbea7 Mon Sep 17 00:00:00 2001
From: Thomas Ieong
Date: Sat, 4 Mar 2023 00:01:54 +0100
Subject: gnu: Add go-github-com-djherbis-atime.
* gnu/packages/golang-xyz.scm (go-github-com-djherbis-atime): New variable.
Signed-off-by: Sharlatan Hellseher
Change-Id: I320070d68e7f590f830060904f5cbdf59d839d1d
---
gnu/packages/golang-xyz.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)
(limited to 'gnu/packages')
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index c2484aae6b..778868001d 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1,4 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2023 Thomas Ieong
;;;
;;; This file is part of GNU Guix.
;;;
@@ -32,6 +33,28 @@
;;;
;;; Code:
+(define-public go-github-com-djherbis-atime
+ (package
+ (name "go-github-com-djherbis-atime")
+ (version "1.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/djherbis/atime")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0xsz55zpihd9wyrj6qvm3miqzb6x3mnp5apzs0dx1byndhb8adpq"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/djherbis/atime"))
+ (home-page "https://github.com/djherbis/atime")
+ (synopsis "Access Times for files")
+ (description "Package atime provides a platform-independent way to get
+atimes for files.")
+ (license license:expat)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar
--
cgit v1.2.3