From ff799a1a956a3cf636774701f632c779d08589bf Mon Sep 17 00:00:00 2001
From: Efraim Flashner <efraim@flashner.co.il>
Date: Wed, 6 Nov 2024 12:42:39 +0200
Subject: gnu: tinyxml: Honor the #:tests? flag.

* gnu/packages/xml.scm (tinyxml)[arguments]: Adjust the custom 'check
phase to honor the #:tests? flag.

Change-Id: Id085358cc07572be3bcee887c825c826f1b00f58
---
 gnu/packages/xml.scm | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 4a3936b66d..575cc016bb 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -1283,7 +1283,9 @@ UTF-8 and UTF-16 encoding.")
                      "tinyxmlparser.cpp" "tinystr.cpp"
                      "-o" "libtinyxml.so")))
          (replace 'check
-           (lambda _ (invoke "./xmltest")))
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests?
+               (invoke "./xmltest"))))
          (replace 'install
            (lambda* (#:key outputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))
-- 
cgit v1.2.3