From dbb4c665e4d17aa7fdc39220ef79560c545628d3 Mon Sep 17 00:00:00 2001
From: Ludovic Courtès <ludo@gnu.org>
Date: Sun, 8 Nov 2020 23:05:56 +0100
Subject: gnu: fontutils: Remove PDF files from the "doc" output.

* gnu/packages/fontutils.scm (fontconfig)[arguments]: Add
'remove-pdf-files' phase.
---
 gnu/packages/fontutils.scm | 7 +++++++
 1 file changed, 7 insertions(+)

diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 1760d65f01..516aca33ea 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -373,6 +373,13 @@ Font Format (WOFF).")
                             (copy-recursively source target)
                             (delete-file-recursively source)))
                         '("man3" "man5"))
+              #t)))
+        (add-after 'install 'remove-pdf-files
+          (lambda* (#:key outputs #:allow-other-keys)
+            ;; By default PDF versions of the user and development manuals are
+            ;; installs but they bring nothing useful.  Remove them.
+            (let ((doc (assoc-ref outputs "doc")))
+              (for-each delete-file (find-files doc "\\.pdf$"))
               #t))))))
    (synopsis "Library for configuring and customizing font access")
    (description
-- 
cgit v1.2.3