From afc720d34c43a2fcf0b5871226c15ad6c5f73697 Mon Sep 17 00:00:00 2001 From: Federico Beffa Date: Tue, 23 Dec 2014 17:51:40 +0100 Subject: gnu: matplotlib: Comment out python2-matplotlib. * gnu/packages/python.scm (python2-matplotlib, python2-scipy, python2-numpy): Comment out python2-matplotlib and the packages making use of it as the generation of the derivation of these packages takes very long. --- gnu/packages/python.scm | 72 ++++++++++++++++++++++++------------------------- 1 file changed, 36 insertions(+), 36 deletions(-) diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm index f81ab695af..2ff258fb4b 100644 --- a/gnu/packages/python.scm +++ b/gnu/packages/python.scm @@ -2011,17 +2011,17 @@ capabilities.") (find-files "." ".*")))))) ,phases))))))) -(define-public python2-numpy - (let ((numpy (package-with-python2 python-numpy))) - (package (inherit numpy) - ;; Make sure we use exactly PYTHON2-NUMPYDOC, which is customized for - ;; Python 2. Since it is also an input to PYTHON2-MATPLOTLIB, we need to - ;; import the right version of 'matplotlib' as well. - (inputs `(("python2-numpydoc" ,python2-numpydoc) - ("python2-matplotlib" ,python2-matplotlib) - ,@(alist-delete "python-numpydoc" - (alist-delete "python-matplotlib" - (package-inputs numpy)))))))) +;; (define-public python2-numpy +;; (let ((numpy (package-with-python2 python-numpy))) +;; (package (inherit numpy) +;; ;; Make sure we use exactly PYTHON2-NUMPYDOC, which is customized for +;; ;; Python 2. Since it is also an input to PYTHON2-MATPLOTLIB, we need to +;; ;; import the right version of 'matplotlib' as well. +;; (inputs `(("python2-numpydoc" ,python2-numpydoc) +;; ("python2-matplotlib" ,python2-matplotlib) +;; ,@(alist-delete "python-numpydoc" +;; (alist-delete "python-matplotlib" +;; (package-inputs numpy)))))))) (define-public python-pyparsing (package @@ -2227,22 +2227,22 @@ ipython shell, web application servers, and six graphical user interface toolkits.") (license psfl))) -(define-public python2-matplotlib - (let ((matplotlib (package-with-python2 python-matplotlib))) - (package (inherit matplotlib) - ;; Make sure we use exactly PYTHON2-NUMPYDOC, which is - ;; customized for Python 2. - (propagated-inputs - `(("python2-py2cairo" ,python2-py2cairo) - ("python2-pygobject-2" ,python2-pygobject-2) - ,@(alist-delete "python-pycairo" - (alist-delete "python-pygobject" - (package-propagated-inputs - matplotlib))))) - (inputs - `(("python2-numpydoc" ,python2-numpydoc) - ,@(alist-delete "python-numpydoc" - (package-inputs matplotlib))))))) +;; (define-public python2-matplotlib +;; (let ((matplotlib (package-with-python2 python-matplotlib))) +;; (package (inherit matplotlib) +;; ;; Make sure we use exactly PYTHON2-NUMPYDOC, which is +;; ;; customized for Python 2. +;; (propagated-inputs +;; `(("python2-py2cairo" ,python2-py2cairo) +;; ("python2-pygobject-2" ,python2-pygobject-2) +;; ,@(alist-delete "python-pycairo" +;; (alist-delete "python-pygobject" +;; (package-propagated-inputs +;; matplotlib))))) +;; (inputs +;; `(("python2-numpydoc" ,python2-numpydoc) +;; ,@(alist-delete "python-numpydoc" +;; (package-inputs matplotlib))))))) ;; Scipy 0.14.0 with Numpy 0.19.X fails several tests. This is known and ;; planned to be fixed in 0.14.1. It is claimed that the failures can safely @@ -2341,15 +2341,15 @@ the SciPy stack. It provides many user-friendly and efficient numerical routines such as routines for numerical integration and optimization.") (license bsd-3))) -(define-public python2-scipy - (let ((scipy (package-with-python2 python-scipy))) - (package (inherit scipy) - ;; Use packages customized for python-2. - (inputs `(("python2-matplotlib" ,python2-matplotlib) - ("python2-numpy" ,python2-numpy) - ,@(alist-delete "python-matplotlib" - (alist-delete "python-numpy" - (package-inputs scipy)))))))) +;; (define-public python2-scipy +;; (let ((scipy (package-with-python2 python-scipy))) +;; (package (inherit scipy) +;; ;; Use packages customized for python-2. +;; (inputs `(("python2-matplotlib" ,python2-matplotlib) +;; ("python2-numpy" ,python2-numpy) +;; ,@(alist-delete "python-matplotlib" +;; (alist-delete "python-numpy" +;; (package-inputs scipy)))))))) (define-public python-sqlalchemy (package -- cgit v1.2.3 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87
Taken from Gentoo and adapted to fix the build using GCC 10. See:
https://bugs.gentoo.org/705730.

--- a/mk/com32.mk
+++ b/mk/com32.mk
@@ -47,6 +47,7 @@ GCCOPT += $(call gcc_ok,-falign-functions=0,-malign-functions=0)
 GCCOPT += $(call gcc_ok,-falign-jumps=0,-malign-jumps=0)
 GCCOPT += $(call gcc_ok,-falign-labels=0,-malign-labels=0)
 GCCOPT += $(call gcc_ok,-falign-loops=0,-malign-loops=0)
+GCCOPT += $(call gcc_ok,-fcommon)
 
 ifeq ($(FWCLASS),EFI)
 GCCOPT += -mno-red-zone
--- a/mk/elf.mk
+++ b/mk/elf.mk
@@ -42,6 +42,7 @@ GCCOPT += $(call gcc_ok,-falign-functions=0,-malign-functions=0)
 GCCOPT += $(call gcc_ok,-falign-jumps=0,-malign-jumps=0)
 GCCOPT += $(call gcc_ok,-falign-labels=0,-malign-labels=0)
 GCCOPT += $(call gcc_ok,-falign-loops=0,-malign-loops=0)
+GCCOPT += $(call gcc_ok,-fcommon)
 
 com32 = $(topdir)/com32
 core = $(topdir)/core
--- a/mk/embedded.mk
+++ b/mk/embedded.mk
@@ -51,6 +51,7 @@ GCCOPT    += $(call gcc_ok,-falign-jumps=0,-malign-jumps=0)
 GCCOPT    += $(call gcc_ok,-falign-labels=0,-malign-labels=0)
 GCCOPT    += $(call gcc_ok,-falign-loops=0,-malign-loops=0)
 GCCOPT    += $(call gcc_ok,-fvisibility=hidden)
+GCCOPT    += $(call gcc_ok,-fcommon)
 
 LIBGCC    := $(shell $(CC) $(GCCOPT) --print-libgcc)
 
--- a/mk/lib.mk
+++ b/mk/lib.mk
@@ -28,6 +28,7 @@ GCCOPT += $(call gcc_ok,-falign-functions=0,-malign-functions=0)
 GCCOPT += $(call gcc_ok,-falign-jumps=0,-malign-jumps=0)
 GCCOPT += $(call gcc_ok,-falign-labels=0,-malign-labels=0)
 GCCOPT += $(call gcc_ok,-falign-loops=0,-malign-loops=0)
+GCCOPT += $(call gcc_ok,-fcommon)
 
 INCLUDE	= -I$(SRC)
 STRIP	= strip --strip-all -R .comment -R .note
--- a/mk/efi.mk
+++ b/mk/efi.mk
@@ -7,7 +7,7 @@ core = $(topdir)/core
 # Set up architecture specifics; for cross compilation, set ARCH as apt
 # gnuefi sets up architecture specifics in ia32 or x86_64 sub directories
 # set up the LIBDIR and EFIINC for building for the appropriate architecture
-GCCOPT := $(call gcc_ok,-fno-stack-protector,)
+GCCOPT := $(call gcc_ok,-fno-stack-protector,) $(call gcc_ok,-fcommon)
 EFIINC = $(objdir)/include/efi
 LIBDIR  = $(objdir)/lib
 
diff --git a/dos/string.h b/dos/string.h
index f648de2..a502132 100644
--- a/dos/string.h
+++ b/dos/string.h
@@ -5,12 +5,13 @@
 #ifndef _STRING_H
 #define _STRING_H
 
+#include <stddef.h>
+
 /* Standard routines */
 #define memcpy(a,b,c)	__builtin_memcpy(a,b,c)
 #define memmove(a,b,c)	__builtin_memmove(a,b,c)
 #define memset(a,b,c)	__builtin_memset(a,b,c)
 #define strcpy(a,b)	__builtin_strcpy(a,b)
-#define strlen(a)	__builtin_strlen(a)
 
 /* This only returns true or false */
 static inline int memcmp(const void *__m1, const void *__m2, unsigned int __n)
@@ -21,6 +22,13 @@ static inline int memcmp(const void *__m1, const void *__m2, unsigned int __n)
     return rv;
 }
 
+static inline size_t strlen(const char *s)
+{
+    size_t len = 0;
+    while (*s++) len++;
+    return len;
+}
+
 extern char *strchr(const char *s, int c);
 
 #endif /* _STRING_H */