From 712f52ace3f2b48ba3b53e81da5aa9a1a3e99df5 Mon Sep 17 00:00:00 2001 From: Tobias Geerinckx-Rice Date: Wed, 6 May 2020 23:06:03 +0200 Subject: gnu: mu: Update to 1.4.4. * gnu/packages/mail.scm (mu): Update to 1.4.4. [source]: Update URI. --- gnu/packages/mail.scm | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm index 2a6286fb16..fde1ec30bc 100644 --- a/gnu/packages/mail.scm +++ b/gnu/packages/mail.scm @@ -715,15 +715,15 @@ security functionality including PGP, S/MIME, SSH, and SSL.") (define-public mu (package (name "mu") - (version "1.4") + (version "1.4.4") (source (origin (method url-fetch) (uri (string-append "https://github.com/djcb/mu/releases/" - "download/" (version-major+minor version) "/" + "download/" version "/" "mu-" version ".tar.xz")) (sha256 (base32 - "1ay68rhlngnp2zm6wdmzgr1fsal3spz61swcxlaz5y215qvgjfpy")))) + "0pmx8zh5fsfhkdl0cr7ydcv6cywhxbgavnjrfr5p2ibz9gx3q3vf")))) (build-system gnu-build-system) (native-inputs `(("pkg-config" ,pkg-config) -- cgit v1.2.3 href='/guix/log/gnu'>logtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-08-11 10:01:01 +0200
committerMarius Bakke <marius@gnu.org>2021-08-11 23:19:02 +0200
commite65bcfda22fe4e3a0f6fe9b4af9f17e6a567f692 (patch)
tree0d673c757221d2492074b736fda00732cab14d63 /gnu
parent443e7f6338049d39427439fc5d997f8c59916fe1 (diff)
downloadguix-e65bcfda22fe4e3a0f6fe9b4af9f17e6a567f692.tar.gz
guix-e65bcfda22fe4e3a0f6fe9b4af9f17e6a567f692.zip
gnu: rapidjson: Remove unused configure flag.
* gnu/packages/web.scm (rapidjson)[arguments]: Remove #:configure-flags, as the entry is not honored by the build system and would only affect tests and examples, which are not installed. [source](snippet): Remove trailing #t.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/web.scm9
1 files changed, 3 insertions, 6 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 432ed3c445..ff53333169 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -1381,8 +1381,7 @@ current version of any major web browser.")
'(begin
;; Remove code using the problematic JSON license (see
;; <https://www.gnu.org/licenses/license-list.html#JSON>).
- (delete-file-recursively "bin/jsonchecker")
- #t))))
+ (delete-file-recursively "bin/jsonchecker")))))
(build-system cmake-build-system)
(arguments
(if (string-prefix? "aarch64" (or (%current-target-system)
@@ -1392,10 +1391,8 @@ current version of any major web browser.")
(add-after 'unpack 'patch-aarch-march-detection
(lambda _
(substitute* (find-files "." "^CMakeLists\\.txt$")
- (("native") "armv8-a"))
- #t))))
- ;; Disable CPU optimization for reproducibility.
- '(#:configure-flags '("-DRAPIDJSON_ENABLE_INSTRUMENTATION_OPT=OFF"))))
+ (("native") "armv8-a"))))))
+ '()))
(home-page "https://github.com/Tencent/rapidjson")
(synopsis "JSON parser/generator for C++ with both SAX/DOM style API")
(description