From 278e1c090e8b567169934de293649abf268eae53 Mon Sep 17 00:00:00 2001 From: Ricardo Wurmus Date: Mon, 21 Jun 2021 17:51:27 +0200 Subject: gnu: Add r-residualmatrix. * gnu/packages/bioconductor.scm (r-residualmatrix): New variable. --- gnu/packages/bioconductor.scm | 31 +++++++++++++++++++++++++++++++ 1 file changed, 31 insertions(+) diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm index 6845894e97..1d4a033038 100644 --- a/gnu/packages/bioconductor.scm +++ b/gnu/packages/bioconductor.scm @@ -6205,6 +6205,37 @@ classification (assignment) methods. It also contains a Shiny application for interactive exploration of results.") (license license:gpl2+))) +(define-public r-residualmatrix + (package + (name "r-residualmatrix") + (version "1.2.0") + (source + (origin + (method url-fetch) + (uri (bioconductor-uri "ResidualMatrix" version)) + (sha256 + (base32 + "0p7va19aw0j6anx7ck879kbi5cn7dy712h5ia94adr38ssismv1v")))) + (properties + `((upstream-name . "ResidualMatrix"))) + (build-system r-build-system) + (propagated-inputs + `(("r-delayedarray" ,r-delayedarray) + ("r-matrix" ,r-matrix) + ("r-s4vectors" ,r-s4vectors))) + (native-inputs + `(("r-knitr" ,r-knitr))) + (home-page "https://github.com/LTLA/ResidualMatrix") + (synopsis "Create a DelayedMatrix of regression residuals") + (description + "This package implements tools for delayed computation of a matrix of +residuals after fitting a linear model to each column of an input matrix. It +also supports partial computation of residuals where selected factors are to +be preserved in the output matrix. It implements a number of efficient +methods for operating on the delayed matrix of residuals, most notably matrix +multiplication and calculation of row/column sums or means.") + (license license:gpl3))) + (define-public r-mast (package (name "r-mast") -- cgit v1.2.3 nt'>
diff options
context:
space:
mode:
Diffstat
-rw-r--r--gnu/packages/tls.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 17dcb407ac..6b131657f9 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -413,7 +413,7 @@ required structures.")
(package
(inherit openssl)
(name "openssl")
- (version "1.1.1a")
+ (version "1.1.1b")
(source (origin
(method url-fetch)
(uri (list (string-append "https://www.openssl.org/source/openssl-"
@@ -426,7 +426,7 @@ required structures.")
(patches (search-patches "openssl-1.1-c-rehash-in.patch"))
(sha256
(base32
- "0hcz7znzznbibpy3iyyhvlqrq44y88plxwdj32wjzgbwic7i687w"))))
+ "0jza8cmznnyiia43056dij1jdmz62dx17wsn0zxksh9h6817nmaw"))))
(outputs '("out"
"doc" ; 6.8 MiB of man3 pages and full HTML documentation
"static")) ; 6.4 MiB of .a files