aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/video.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index e2922dec70..561268aabd 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1838,14 +1838,14 @@ audio/video codec library.")
(define-public ffmpeg-2.8
(package
(inherit ffmpeg-3.4)
- (version "2.8.20")
+ (version "2.8.22")
(source (origin
(method url-fetch)
(uri (string-append "https://ffmpeg.org/releases/ffmpeg-"
version ".tar.xz"))
(sha256
(base32
- "1ivnfqmfnp3zmn1q2dxy4p85427y3r6d3jbnl5kprr7lqckf6rl5"))))
+ "0c8m4hhv2k5fybha908wzrpnf3wqkq52hayl658jq4bah0igdfqz"))))
(arguments
`(#:tests? #f ; XXX: Enable them later, if required
#:configure-flags
ef='/guix/commit/gnu/services/messaging.scm?id=2ded865665850d9f257ee62a995658c1381a8f4a'>services: prosody: Use 'invoke' rather than 'system*'....* gnu/services/messaging.scm (prosody-shepherd-service): Replace SYSTEM* with INVOKE. Clément Lassieur 2018-05-11services: bitlbee: Add plugins....* doc/guix.texi (Bitlbee Service): Add plugins. * gnu/services/messaging.scm (<bitlbee-configuration>): Add plugins argument. (bitlbee-shepherd-service): Update config file. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Pierre-Antoine Rouby 2018-05-01services: prosody: Add a default value to the prosody-service-type....* gnu/services/messaging.scm (prosody-service-type)[default-value]: New field. Clément Lassieur 2018-05-01services: prosody: Add a description to the prosody-service-type....* gnu/services/messaging.scm (prosody-service-type)[description]: New field. Clément Lassieur 2018-03-03services: messaging: Prosody config supports file-like objects....* doc/guix.texi (Messaging Services): Update accordingly. * gnu/services/configuration.scm (serialize-configuration, serialize-maybe-stem, serialize-package): Return strings or string-valued gexps (these procedures were only used for their side-effects). * gnu/services/messaging.scm (serialize-field, serialize-field-list, enclose-quotes, serialize-raw-content, serialize-ssl-configuration, serialize-virtualhost-configuration-list, serialize-int-component-configuration-list, serialize-ext-component-configuration-list, serialize-virtualhost-configuration, serialize-int-component-configuration, serialize-ext-component-configuration, serialize-prosody-configuration): Return strings or string-valued gexps and stop printing. (prosody-activation): Use SERIALIZE-PROSODY-CONFIGURATION's return value with MIXED-TEXT-FILE instead of using its output with PLAIN-FILE. (serialize-non-negative-integer, serialize-non-negative-integer-list): Convert numbers to strings. (file-object?, serialize-file-object, file-object-list?, serialize-file-object-list): New procedures. (ssl-configuration)[capath, cafile], (prosody-configuration)[plugin-paths, groups-file]: Replace FILE-NAME with FILE-OBJECT. * guix/gexp.scm (file-like?): New exported procedure. Clément Lassieur 2018-01-15doc: Deprecate 'bitlbee-service' procedure....* gnu/services/messaging.scm (bitlbee-service): Mark as deprecated. * doc/guix.texi (Messaging Services): Document 'bitlbee-service-type' and 'bitlbee-configuration'. Remove 'bitlbee-service'. Ludovic Courtès 2018-01-15services: bitlbee: Move to (gnu services messaging)....* gnu/services/networking.scm (<bitlbee-configuration>) (bitlbee-shepherd-service, %bitlbee-accounts, %bitlbee-activation) (bitlbee-service-type, bitlbee-service): Move to... * gnu/services/messaging.scm: ... here. * doc/guix.texi (Networking Services): Move 'bitlbee-service' doc to... (Messaging Services): ... here. Ludovic Courtès 2017-12-24services: messaging: Use HTTPS for prosody.im URLs....* gnu/services/messaging.scm (prosody-configuration): Use HTTPS whenever referring to prosody.im URLs in documentation. * doc/guix.texi (Messaging Services): Likewise. Tobias Geerinckx-Rice 2017-11-28services: configuration: Show default values of list types....* doc/guix.texi (Messaging Services): Regenerate it. * gnu/services/configuration.scm (show-default?): Check VAL rather than DEFAULT. * gnu/services/messaging.scm (show-default?): Check VAL rather than DEFAULT. (prosody-configuration)[modules-enabled]: Remove default value from docstring. Clément Lassieur 2017-11-26services: prosody: Add support for disable-sasl-mechanisms....* doc/guix.texi (Messaging Services): Update accordingly. * gnu/services/messaging.scm (prosody-configuration)[disable-sasl-mechanisms]: New field. Clément Lassieur 2017-11-26services: prosody: Allow to add raw content to the config file....* doc/guix.texi (Messaging Services): Update accordingly. * gnu/services/messaging.scm (prosody-configuration)[raw-content]: New field. (raw-content?, serialize-raw-content): New procedures. Clément Lassieur 2017-11-26services: prosody: Add support for http-max-content-size....* doc/guix.texi (Messaging Services): Update accordingly. * gnu/services/messaging.scm (prosody-configuration)[http-max-content-size]: New field. Clément Lassieur 2017-11-26services: prosody: Add support for http-external-url....* doc/guix.texi (Messaging Services): Update accordingly. * gnu/services/messaging.scm (prosody-configuration)[http-external-url]: New field. Clément Lassieur 2017-11-26services: prosody: Adapt to Prosody 0.10.0....* doc/guix.texi (Messaging Services): Add "mam" as a module example. Document 'prosodyctl check'. Replace 'prosodyctl cert request' with 'prosodyctl cert import'. Regenerate it. * gnu/services/messaging.scm (serialize-module-list): Remove "posix" from the default modules list because it is now automatically loaded. (ssl-configuration)[key, certificate]: Remove them because they are now automatically located. Fix their docstrings. (%default-modules-enabled): Add "carbons" and "blocklist". (prosody-configuration)[certificates]: Set default directory from which certificates/keys will be automatically located. Clément Lassieur 2017-03-24services: Factorize define-maybe macro....* gnu/services/configuration.scm (id): New procedure extracted from define-configuration. (define-maybe): New exported procedure, moved from messaging.scm. * gnu/services/messaging.scm (define-maybe): Remove it. (id): Move declaration inside define-all-configurations which is now the only caller procedure. Signed-off-by: Clément Lassieur <clement@lassieur.org> Mathieu Othacehe 2017-03-08services: prosody: Use 'id' to introduce unhygienic top-level identifiers....* gnu/services/messaging.scm (define-all-configurations): Use 'id' to introduce raw/literal/unhygienic top-level identifiers. Fixes compilation with Guile 2.2. Ludovic Courtès 2017-03-08services: prosody: Make sure 'id' is available at expansion time....* gnu/services/messaging.scm (id): Use 'define-syntax-rule' instead of 'define' to make sure 'id' is available at expansion time. Ludovic Courtès