aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/samba.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index 0ce46056f5..41e37050a5 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -236,14 +236,14 @@ Desktops into Active Directory environments using the winbind daemon.")
(define-public talloc
(package
(name "talloc")
- (version "2.1.13")
+ (version "2.1.14")
(source (origin
(method url-fetch)
(uri (string-append "https://www.samba.org/ftp/talloc/talloc-"
version ".tar.gz"))
(sha256
(base32
- "0iv09iv385x69gfzvassq6m3y0rd8ncylls95dm015xdy3drkww4"))))
+ "1kk76dyav41ip7ddbbf04yfydb4jvywzi2ps0z2vla56aqkn11di"))))
(build-system gnu-build-system)
(arguments
'(#:phases
nd testing. You're welcome to discuss this road map on guix-devel@gnu.org or #guix on the Libera Chat IRC network! * Features scheduled for 1.0 - larger & more robust build farm + we need a powerful, dedicated front-end + armhf-linux build machine + leave Hydra in favor of 'guix publish' + custom code? - more OS features + LVM support + encrypted root + configurable name service switch + whole-system unit tests, using VMs - more service definitions + mcron, postfix(?), wicd(?), etc. - better 'guix system' + 'reconfigure' should be able to restart non-essential services + support for '--list-generations' and '--delete-generations' - better 'guix pull' + using Git to fetch the source instead of re-downloading everything + build more quickly + install new .mo files and new manual + authentication of the Guix source: use signed commits? - simplified, purely declarative service list in 'operating-system' + it should be possible to inspect the service instance declarations and settings - GUIs + integrate guix-web? + guile-ncurses installer? - 'guix publish'? * Features for later - complete GNU/Hurd port - use content-based addressing when downloading substitutes to reduce bandwidth requirements + design nar v2 format where file contents are replaced by their hashes + leverage /gnu/store/.links - binary origin tracking + keep signatures in sqlite.db + preserve signatures upon import/export - peer-to-peer distribution of updates (GNUnet?) - more deterministic builds + identify & fix sources of non-determinism in builds + strengthen guix-daemon containers to further increase reproducibility + trusting-trust: bootstrap with different tool chains + fixed-point: re-bootstrap until fixed point is reached + distributed validation: compare contents of store items with others * resist a hydra.gnu.org compromise - reproducible containers: mix of 'guix environment' and 'guix system vm' - execute code with least privilege + build containers like guix-daemon does + provide a Plash-like interface in Bash - daemon rewritten in Guile - more shepherd integration + monitor network interfaces and start/stop events based on that + include a DHCP client written in Scheme