aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xdisorg.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index dc31cedeba..0027630da7 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -897,7 +897,7 @@ move windows, switch between desktops, etc.).")
(define-public scrot
(package
(name "scrot")
- (version "1.9")
+ (version "1.11")
(source
(origin
(method git-fetch)
@@ -907,7 +907,7 @@ move windows, switch between desktops, etc.).")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "140wczmmxjp5fkrp6qg5rbq4hdwfslxb23jdk91ls8fjxdp9hafz"))))
+ (base32 "1syip5ai4kn62qbhpf710wj60z7jzpkqhkchlbxhs322wmhhidkp"))))
(build-system gnu-build-system)
(native-inputs
(list autoconf autoconf-archive automake pkg-config))
doc: Suggest more RAM for "Running Guix in a VM".Ludovic Courtès Fixes <https://issues.guix.gnu.org/57474>. Reported by Michael F. Lamb <mike@orbital.rodeo>. Running 'guix pull' to target current revisions would lead to memory exhaustion. Bumping the memory size works around that. * doc/guix.texi (Running Guix in a VM): Change "-m 1024" to "-m 2048". 2022-09-01gnu: fail2ban-service-type: Fix documentation typos.muradm Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> 2022-08-30guix system: Use standard cross and native build options.Thiago Jung Bauermann This change prevents guix system from erroring out with an ugly backtrace when it's passed an invalid value to the “--system” or “--target” option. It also adds the “--list-systems” and “--list-targets” options. The manual section about guix system doesn't mention the “--target” option, so add it there. * guix/scripts/system (show-help): Call show-cross-build-options-help and show-native-build-options-help. (%options): Remove own implementation of “system” and “target” options and use the ones in %standard-cross-build-options and %standard-native-build-options. * doc/guix.texi (Invoking guix system): Document “--target” option. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org> 2022-08-30bootloader: Add device-tree-support? option.Reza Alizadeh Majd In some specific cases where the device tree file is already loaded in RAM, it can be preferable that the bootloader does not try to use a device tree from the Linux kernel tree. * gnu/bootloader.scm (<bootloader-configuration>)[device-tree-support?]: New field. * gnu/bootloader/extlinux.scm (extlinux-configuration-file): Add FDTDIR line based on <device-tree-support?> field of <bootloader-configuration>. * doc/guix.texi (Bootloader Configuration)[device-tree-support?]: Add documentation for the new field. 2022-08-28services: Add lightdm-service-type.Maxim Cournoyer * gnu/services/lightdm.scm: New service. * tests/services/lightdm.scm: Test it. * doc/guix.texi (X Window): Document it. * gnu/local.mk (GNU_SYSTEM_MODULES): Register it. Co-authored-by: L p R n d n <guix@lprndn.info> Co-authored-by: Ricardo Wurmus <rekado@elephly.net> 2022-08-28gnu: security: Add fail2ban-service-type.muradm * gnu/services/security.scm: New module. * gnu/tests/security.scm: New module. * gnu/local.mk: Add new security module and tests. * doc/guix.text: Add fail2ban-service-type documentation. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> 2022-08-26gnu: greetd-service-type: Add supplementary groups to greeter.muradm * gnu/services/base.scm (<greetd-configuration>) [greeter-supplementary-groups]: New field. (%greetd-accounts): Rename to... (greetd-accounts): ... this. Convert to a function that takes a config argument. Use greeter-supplementary-groups. (greetd-service-type): Adjust accordingly. * gnu/tests/desktop.scm (%minimal-services): Add test for greeter-supplementary-groups. * doc/guix.texi ("Base Services")[greetd-service-type]: Document greeter-supplementary-groups. 2022-08-26gnu: seatd-service-type: Use seat group.muradm * gnu/services/desktop.scm (seatd-group-sanitizer): New variable. (<seatd-configuration>)[user]: Removed field. [group]: Changed to "seat". Sanitize via seatd-group-sanitizer. (seatd-accounts): New variable. (seatd-environment): Adjust to <seatd-configuration> ABI. (seatd-service-type)[extensions]: Add account-service-type with seatd-accounts. * gnu/tests/desktop.scm (run-minimal-desktop-test): Check for correct ownership of $SEATD_SOCK. * doc/guix.texi ("Desktop Services")[seatd-service-type]: Mention that users may need to become members of the "seat" group. Update default value for group field. Add explanation on seatd.sock file. Remove dropped user field. 2022-08-25doc: Replace remaining 'unset mentions with %unset-value.Maxim Cournoyer * doc/guix.texi (Networking Services): Replace 'unset with %unset-value. (Power Management Services): Likewise. (Complex Configurations): Likewise. 2022-08-24services: configuration: Add a 'maybe-value-set?' procedure.Maxim Cournoyer * gnu/services/configuration.scm (maybe-value-set?): New procedure. * doc/guix.texi (Complex Configurations): Document it. Remove comment showing usage of 'maybe-string' with a default value, which doesn't make sense. Co-authored-by: Attila Lendvai <attila@lendvai.name> 2022-08-20doc: Fix typos.Julien Lepiller * doc/guix.texi: Fix various typos found by translators. 2022-08-19doc: Add files, xdg-configuration and symlink-manager home services.Andrew Tropin * doc/guix.texi (Essential Home Services): Add files, xdg-configuration-files and symlink-manager home services. 2022-08-14doc: Note the pitfalls of man 8 mount.Tobias Geerinckx-Rice * doc/guix.texi (File Systems): Warn against flags presented as options. 2022-08-14doc: Remove extraneous ‘Note…’.Tobias Geerinckx-Rice * doc/guix.texi (File Systems): Remove a ‘Note that’ & begin a new paragraph.