aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/fontutils.scm13
1 files changed, 11 insertions, 2 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index bdabe2adee..300290a21d 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2013, 2014, 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014, 2016 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2016 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2016, 2017, 2020, 2022 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017, 2020, 2022, 2023 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Rene Saavedra <rennes@openmailbox.org>
;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2017 Nikita <nikita@n0.is>
@@ -97,7 +97,16 @@
(arguments
;; The use of "freetype-config" is deprecated, but other packages still
;; depend on it.
- `(#:configure-flags (list "--enable-freetype-config")))
+ `(#:configure-flags (list "--enable-freetype-config")
+ #:disallowed-references (,pkg-config)
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'remove-reference-to-pkg-config
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (substitute* (string-append out "/bin/freetype-config")
+ (((search-input-file inputs "/bin/pkg-config"))
+ "pkg-config"))))))))
(native-inputs
(list pkg-config))
(propagated-inputs
..André Batista 2020-06-23doc: cookbook: Fix typos....Ludovic Courtès 2020-06-23doc: cookbook: Tweak intro to the REPL....Ludovic Courtès 2020-06-23doc: cookbook: Mention "guix hash -rx" for Git checkouts....Ludovic Courtès 2020-06-23doc: cookbook: Clarify 'git-fetch' conventions....Ludovic Courtès 2020-06-04doc: cookbook: Add entry about getting substitutes through Tor....Brice Waegeneire 2020-06-02doc: cookbook: Add entry about Wireguard VPN....Marcin Karpezo 2020-05-25doc: cookbook: Add subsection about session locking with xss-lock....Chris Bøg 2020-05-05doc: cookbook: Fix sbcl-ttf-fonts package name....Jean-Baptiste Note 2020-04-30doc: cookbook: Rename stumpwm package to current state....Marcin Karpezo 2020-04-25doc: cookbook: Fix quotes....Nicolas Goaziou 2020-04-24doc: cookbook: Use @file for file names and extensions....Nicolas Goaziou 2020-04-24doc: cookbook: Fix misuses of double spacing....Nicolas Goaziou 2020-04-22doc: cookbook: Explain how to use bind mounts....Matthew Brooks 2020-03-30gnu: Add sbcl-stumpwm-ttf-fonts....Oleg Pykhalov 2020-01-17doc: cookbook: Avoid URL reference to the manual....Ludovic Courtès 2019-11-26doc: cookbook: Add cross-references to the Guile manual....Ludovic Courtès 2019-11-26doc: cookbook: Use @result{} & co. instead of a '>' prompt....Ludovic Courtès 2019-11-26doc: cookbook: Use Texinfo quotes....Ludovic Courtès 2019-11-26doc: cookbook: Add cross-reference about ./pre-inst-env....Ludovic Courtès 2019-11-26doc: cookbook: Use @lisp for Scheme snippets....Ludovic Courtès 2019-10-30doc: Explain how to switch profile from empty shell in "Profiles in Practice"....Pierre Neidhardt 2019-10-28doc: Link to SICP Info page in "A Scheme Crash Course"....Pierre Neidhardt 2019-10-28doc: Finish importing the "Packaging Tutorial"....Pierre Neidhardt 2019-10-28doc: Fix some typos in "Guix Profiles in Practice"....Pierre Neidhardt 2019-10-25doc: cookbook: Use "@lisp" for Scheme snippets....Ludovic Courtès 2019-10-24doc: Add "Guix Profiles in Practice" to the cookbook....Pierre Neidhardt 2019-09-18doc: Add Guix Cookbook....Ricardo Wurmus