aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/protobuf.scm78
1 files changed, 39 insertions, 39 deletions
diff --git a/gnu/packages/protobuf.scm b/gnu/packages/protobuf.scm
index 7269f01c62..8cd805799e 100644
--- a/gnu/packages/protobuf.scm
+++ b/gnu/packages/protobuf.scm
@@ -563,49 +563,49 @@ source files.")
"12hp1clg83jfl35x1h2ymzpj5w83wrnqw7hjfc6mqa8lsvpw535r"))))
(build-system ruby-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'do-not-use-bundler-for-tests
- (lambda _
- (substitute* "spec/spec_helper.rb"
- (("Bundler\\.setup.*") ""))))
- (add-after 'unpack 'relax-version-requirements
- (lambda _
- (substitute* ((@@ (guix build ruby-build-system) first-gemspec))
- (("'rake',.*")
- "'rake'\n")
- (("\"rubocop\",.*")
- "'rubocop'\n")
- (("\"parser\",.*")
- "'parser'\n"))))
- (add-after 'unpack 'patch-protoc
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "lib/protobuf/tasks/compile.rake"
- (("\"protoc\"")
- (string-append "\"" (search-input-file inputs "bin/protoc")
- "\"")))))
- (add-after 'unpack 'skip-failing-test
- ;; See: https://github.com/ruby-protobuf/protobuf/issues/419
- (lambda _
- (substitute* "spec/lib/protobuf/rpc/connectors/ping_spec.rb"
- (("expect\\(::IO\\)\\.to receive\\(:select\\).*" all)
- (string-append " pending\n" all)))))
- (add-after 'replace-git-ls-files 'replace-more-git-ls-files
- (lambda _
- (substitute* ((@@ (guix build ruby-build-system) first-gemspec))
- (("`git ls-files -- \\{test,spec,features\\}/*`")
- "`find test spec features -type f | sort`")
- (("`git ls-files -- bin/*`")
- "`find bin -type f | sort`"))))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "rspec")))))))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'do-not-use-bundler-for-tests
+ (lambda _
+ (substitute* "spec/spec_helper.rb"
+ (("Bundler\\.setup.*") ""))))
+ (add-after 'unpack 'relax-version-requirements
+ (lambda _
+ (substitute* ((@@ (guix build ruby-build-system) first-gemspec))
+ (("'rake',.*")
+ "'rake'\n")
+ (("\"rubocop\",.*")
+ "'rubocop'\n")
+ (("\"parser\",.*")
+ "'parser'\n"))))
+ (add-after 'unpack 'patch-protoc
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "lib/protobuf/tasks/compile.rake"
+ (("\"protoc\"")
+ (string-append "\"" (search-input-file inputs "bin/protoc")
+ "\"")))))
+ (add-after 'unpack 'skip-failing-test
+ ;; See: https://github.com/ruby-protobuf/protobuf/issues/419
+ (lambda _
+ (substitute* "spec/lib/protobuf/rpc/connectors/ping_spec.rb"
+ (("expect\\(::IO\\)\\.to receive\\(:select\\).*" all)
+ (string-append " pending\n" all)))))
+ (add-after 'replace-git-ls-files 'replace-more-git-ls-files
+ (lambda _
+ (substitute* ((@@ (guix build ruby-build-system) first-gemspec))
+ (("`git ls-files -- \\{test,spec,features\\}/*`")
+ "`find test spec features -type f | sort`")
+ (("`git ls-files -- bin/*`")
+ "`find bin -type f | sort`"))))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "rspec")))))))
(native-inputs
(list ruby-benchmark-ips
ruby-ffi-rzmq
ruby-parser
- ruby-pry-byebug
ruby-pry-stack-explorer
ruby-rake
ruby-rspec
bfe7278f550a1ed4cd76565013feab59'>guix: 'guile' executable ignores GUILE_LOAD_PATH during startup....When starting the 'guix' command, this ensures Guile modules are immediately found instead of being search for in other directories. This reduces the number of 'stat' calls during startup when GUILE_LOAD_PATH is set to (almost) that of "env -i $(type -P guix)". * gnu/packages/aux-files/guile-launcher.c (load_path) (load_compiled_path): New variables. (inner_main): Restore GUILE_LOAD_PATH and GUILE_LOAD_COMPILED_PATH and set %load-path and %load-compiled-path accordingly. (main): Save GUILE_LOAD_PATH and GUILE_LOAD_COMPILED_PATH and unset them. Ludovic Courtès 2020-10-31pack: Relocatable wrapper leaves root available to child processes....Fixes <https://bugs.gnu.org/44261>. Reported by Jan Nieuwenhuizen <janneke@gnu.org>. * gnu/packages/aux-files/run-in-namespace.c (exec_in_user_namespace): Add call to 'prctl'. Call 'mount' for NEW_ROOT and define 'is_tmpfs'. When IS_TMPFS is true, call 'umount' and 'rmdir' after 'waitpid'; otherwise, call 'rm_rf' only when 'waitpid' returns -1 the second time. (exec_with_loader): Call 'prctl'. Remove NEW_ROOT only when 'waitpid' returns -1 the second time, otherwise leave it behind. * tests/guix-pack-relocatable.sh (wait_for_file): New function. Add test. Ludovic Courtès 2020-10-30gnu: linux-libre: Update to 5.9.2....* gnu/packages/linux.scm (linux-libre-5.9-version): Update to 5.9.2. (deblob-scripts-5.9, linux-libre-5.9-pristine-source): Update hashes. * gnu/packages/aux-files/linux-libre/5.9-arm.conf, gnu/packages/aux-files/linux-libre/5.9-arm64.conf, gnu/packages/aux-files/linux-libre/5.9-i686.conf, gnu/packages/aux-files/linux-libre/5.9-x86_64.conf: Update kernel configurations for 5.9.2. Leo Famulari 2020-10-30guix: pack: Fix offset calculation for store directory mount point....Fixes wrapping of non-package things, where the target store directory may differ in length from the original. * guix/scripts/pack.scm (wrapped-package)<build-wrapper>: Define WRAPPER_PROGRAM macro with wrapper's file name. * gnu/packages/aux-files/run-in-namespace.c (main): Offset index by len of that file name. Eric Bavier 2020-10-24gnu: linux-libre: Update to 5.9.1....* gnu/packages/aux-files/linux-libre/5.8-arm.conf, gnu/packages/aux-files/linux-libre/5.8-arm64.conf, gnu/packages/aux-files/linux-libre/5.8-i686.conf, gnu/packages/aux-files/linux-libre/5.8-x86_64.conf: Delete files. * gnu/packages/aux-files/linux-libre/5.9-arm.conf, gnu/packages/aux-files/linux-libre/5.9-arm64.conf, gnu/packages/aux-files/linux-libre/5.9-i686.conf, gnu/packages/aux-files/linux-libre/5.9-x86_64.conf: New files. * Makefile.am (AUX_FILES): Adjust accordingly. * gnu/packages/linux.scm (linux-libre-5.8-version, deblob-scripts-5.8, linux-libre-5.8-pristine-source, linux-libre-5.8-source, linux-libre-headers-5.8, linux-libre-5.8): Remove variables. (linux-libre-5.9-version, deblob-scripts-5.9, linux-libre-5.9-pristine-source, linux-libre-5.9-source, linux-libre-headers-5.9, linux-libre-5.9): New variables. (linux-libre-version, linux-libre-pristine-source, linux-libre-source, linux-libre): Point to linux-libre-5.9*. (linux-libre-with-bpf): Use linux-libre-5.9. Leo Famulari